Question

Matrix N7 - No DHCP over a FO link


  • New Member
  • 11 replies
Hello community,

im having an issue with DHCP, between a trunk from a matix N7 to a C3 switch over a FO link, using VLAN 1, 7, 10 and 11

Basically, everything works when tested directly in the N7. I can get an IP to any machine over DHCP on any VLAN and in any network i desire.

Even when configuring a "trunk" port in another switch with the same exact configuration and plugging it directly to the N7, everything works properly.

But once i try to get an IP in a network inside a given tagged VLAN ( 1,10 and 11) that crosses the FO link from the N7 over to the C3, im unable to get anything else than the one that is given by the untagged VLAN (7).

I contacted the ISP for that FO link but they assured me that the link is a pure Layer2 and anything is accepted inside it. So im lost here. Im almost sure the issue is with the FO link not being able to pass any tagged traffic, but im a bit green with Enterasys so i want to be sure.

heres my config. any help would be great.

Matrix N7

config t
interface vlan 1
ip address 172.16.1.254 255.255.255.0
no shutdown
interface vlan 7
ip address 172.16.7.254 255.255.255.0
ip helper-address 172.16.1.1
no shutdown
interface vlan 10
ip address 172.16.10.254 255.255.255.0
ip helper-address 172.16.1.1
no shutdown
interface vlan 11
ip address 172.16.11.254 255.255.255.0
ip helper-address 172.16.1.1
no shutdown

clear vlan egress 1 host.0.1;ge.1.23,25-48,52,54;rtr.1.1;ge.2.23-48,52;ge.3.37-48
set vlan egress 1 lag.0.1-48;ge.1.1-22,24,49-51,53;ge.2.1-22,49-51,53-54;ge.3.1-36,49-54 untagged
set vlan egress 7 ge.2.24 untagged
set vlan egress 10 lag.0.1-5;ge.1.47-54;ge.2.24,49-54;ge.3.1-2 tagged
set vlan egress 10 host.0.1;ge.1.23 untagged
set vlan egress 11 ge.2.24 tagged

C3

clear vlan egress 1 ge.1.7
set vlan egress 7 ge.1.43 untagged
set vlan egress 10 ge.1.1;ge.1.41-48;lag.0.1-6 tagged
set vlan egress 11 ge.1.43;ge.1.45 tagged
set vlan egress 11 ge.1.7 tagged

Anything else im missing or can try to work around this?

Thank you.

Antonio

1 reply

Userlevel 3
On which ports on each switch are you running the FO link?

can you post your port vlan configuration as well?
"show config port" and just the relevant settings.

Also, please post the following output:
N7:
- show port vlan
- show port egress
- show port discard

C3:
- show vlan portinfo port
- show port discard

I see you have have, on the N7, both VLAN 1 and 10 untagged on ge.1.23 - in most situations this should be only one. But the above output should show this better.

Did you ever try to connect the C3 directly to the N7, using the same ports?

Reply