Header Only - DO NOT REMOVE - Extreme Networks

Problem with QOS configuration


I am new to Extreme networks and trying to figure out how QOS works on. I have been following all the examples and guides located on this site, but have been unable to successfully see QOS working.

I am trying to setup QOS for voice traffic using Summit X450e-48p switches and 8810 Blackdiamond for my core.

Below is a snip it of my configuration:



create qosprofile “QP6”

create vlan “voip”

configure vlan voip tag 50

configure vlan Default add ports all untagged

configure vlan voip add ports all tagged



configure qosprofile QP6 maxbuffer 100 weight 1

configure qosprofile QP6 minbw 0 maxbw 100 ports 1:1

configure qosprofile QP6 minbw 0 maxbw 100 ports 1:2

configure qosprofile QP6 minbw 0 maxbw 100 ports 1:3

configure qosprofile QP6 minbw 0 maxbw 100 ports 1:4 etc, etc,



configure dot1p type 5 qosprofile QP6



I verified the voip phones are using the 801.2p type 5 tagging

When I make a phone call and use the: show port (X) qosmonitor I never see any packets using QP6. Only QP1 and QP8.

This seems very straightforward to setup. What am I missing?

Thanks,

7 replies

Hi Cheyne,

What type of VOIP phones are you using?

Also, do you have LLDP enabled? A lot of times running LLDP commands will resolve the issue.
We are using Polycom phones and LLDP is currently not enabled.
Hi Cheyne,

Please try the steps listed in the following article and let us know if it works after that:
https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-LLDP-for-Extreme-switches...

Thanks,
Matthew

edit 10/14/15: updated link
Userlevel 6
Hi Cheyne,

I know that the dot1p examination by default is enabled on the ports. However, can you please confirm if it is enabled. Because, the switch should be able to examine the dot1p value incoming on the ports to assign the correct qos. Also, please share the following output.

show dot1p

It would also be good if you can apply the following acl on the ports to make sure that the VOIP traffic comes in with the dot1p value of 5.

vi acl_dot1p.pol

entry dot1ptest {
if {
dot1p 5;
}
then {
count voiptraffic;
}
}

Apply this to one of the port where the VOIP traffic comes in
configure access-list acl_dot1p port <> ingress

Hope this helps!
I did a show dot1p and see the dot1p 5 is mapped to Q6 Q1 is mapped to 0 - 4 and 6, Q8 mapped to 7. I also looked at the ports to make sure Ingress 802.1p Examination is Enabled.

I created and added the acl and applied it to the voip ports. Using the qosmonitor command on the ports I'm testing with VOIP phones I still do not see any traffic going into the QP6.
I also tried to enable lldp on the ports, but it had no effect
Userlevel 6
Hi Cheyne,

Thank you for verifying the information. I did a quick test with X450e and this configuration should work well if the packets ingress with the dot1p value. of 5.
Qosmonitor is to monitor the traffic egressing the switch. We should be checking the output in the egress port. So, if my ingress port is 1:1 and egress port is 1:2, I see the following.

(pacman) Slot-1 Stack.29 # sh port 1:2 qosmonitor no-refreshPort Qos Monitor
Port QP1 QP2 QP3 QP4 QP5 QP6 QP7 QP8
Pkt Pkt Pkt Pkt Pkt Pkt Pkt Pkt
Xmts Xmts Xmts Xmts Xmts Xmts Xmts Xmts
===============================================================================
1:2 0 0 0 0 0 5401539 0 0

It works fine in the lab.
As per your configuration, I believe it is from the BD which is the core as the port notation suggests it.

configure qosprofile QP6 minbw 0 maxbw 100 ports 1:1

Can you share the configuration from the X450e to which the IP phones are connected? We need to ensure that the dot1p value is carried till the core switch for the core switch to prioritize the traffic.
Looking forward for the clarification on the setup!

Reply