VoIP video problem


Userlevel 2
We are putting out new Extreme switches (x460 and x440) into different buildings. We are running 15.3.2.111. We use cisco phones for our VoIP. We have models 8945 and 9951 which also provide video. They have worked great in our test building (which was small), however now the video isn't working in the newer deployments. We are using netlogin to authenticate all devices. When a phone is authenticated (mac auth) a UPM profile is ran to turn on lldp and set dscp... You can make calls without a problem. I'm wondering if there is an uplink/downlink setting that we need that I have completely forgot about. Below is what our UPM script. Any help/suggestions would be greatly appreciated! # # Module upm configuration. # create upm profile c_PHONE_UPM #@MetaDataStart #@ScriptDescription This Profile is Used to Provision a Port for a Phone Once i t's Been Authenticated. #@MetaDataEnd create log message PHONE_AUTHENTICATE_SCRIPT if (!$match($EVENT.NAME,USER-AUTHENTICATED)) then create log message PHONE_AUTHENTICATED_CONFIGURING_PORT_$EVENT.USER_PORT configure lldp port $EVENT.USER_PORT advertise system-capabilities configure lldp port $EVENT.USER_PORT advertise vendor-specific med capab ilities # advertise the 802.1Q tag for the Phone Vlan configure lldp port $EVENT.USER_PORT advertise vendor-specific dot1 vlan -name vlan Phone # advertise the DSCP for the phone to use configure lldp ports $EVENT.USER_PORT advertise vendor-specific med poli cy application voice vlan Phone dscp 46 #advertise PoE capabilities (some Cisco phones require this) configure lldp ports $EVENT.USER_PORT advertise vendor-specific med powe r-via-mdi #turn on lldp on the port enable lldp port $EVENT.USER_PORT # ignore 802.1p bits on the edge ports (the phones are sending a Qtag wh ich always have pbits) disable dot1p examination ports $EVENT.USER_PORT # replace the 802.1p bits when forwarding packets enable dot1p replacement ports $EVENT.USER_PORT enable snmp traps lldp ports $EVENT.USER_PORT enable snmp traps lldp ports $EVENT.USER_PORT create log message END_OF_PHONE_AUTHENTICATED_$EVENT.USER_PORT endif if (!$match($EVENT.NAME,USER-UNAUTHENTICATED)) then create log message PHONE_IS_UNAUTHENTICATED_$EVENT.USER_PORT disable lldp port $EVENT.USER_PORT disable snmp traps lldp ports $EVENT.USER_PORT disable snmp traps lldp ports $EVENT.USER_PORT endif

3 replies

Userlevel 6
Hey BW447

Have you tried it where the port is just set to the VLAN and see if it has any issue. I don't think it is the UPM unless you have QOS profiles set and the traffic is not marked correctly.

What would be nice to know is what happens on the same switch? and What happens if you bypass the UPM and set the phone on the correct VLAN?

Thanks
P
Userlevel 2
Hello Mr. Russo, The commands that I was shown for QoS are: #-- create qos queue on all extreme switches create qos qp3 #-- our voice vlan is named Phone configu vlan Phone qos qp3 #-- this command is ran from the UPM script with the variable $port disable dot1p examination port $port config dot1p type 2 qosp qp3 #-- this command is ran from the UPM script with the variable $port enable dot1p replacement port $port Does this look correct or are is there anything else we need to add? Thanks! Blake
Userlevel 6
Hey Blake

if you disable .1p you probably you don't need to set the 1.p value to a queue or replace it unless the next switches inline are looking at .1p

The switch has a hierarchy to how we look at QoS parameters. ACLs have the highest priority, then .1p then VLAN then DSCP. so if you do not use ACL or .1p the switch will then use VLAN.

The commands you issued above are ok and will not affect the switch just may not be needed if the switches are set to disable .1p examination.

Does that help?

P

Reply