06-19-2023 11:45 AM
I want to create communication btw vrf1 to vrf2 using the route leaking feature.
vrf1: 10.55.51.12/32 - destination reachable through default route -next hop 192.168.246.253-
vrf2: 10.50.18.65/27 - ve 1101
Using below commands, communication does not work as expected
vrf vrf1
address-family ipv4 unicast
ip route 10.50.18.64/27 next-hop-vrf vrf2 10.50.18.65
vrf vrf2
address-family ipv4 unicast
ip route 10.55.51.12/32 next-hop-vrf vrf1 192.168.246.253
I'm assuming next hops are correct, please let me know if somebody has faced a similar issue, or if I'm using an incorrect input for this route leaking.
06-20-2023 06:40 AM
Hello,
Thank you for your question. Did you confirm that the source interfaces are UP/UP? If so, we would want to see more of your config.
In my lab I tested with an SLX 9250 running SLX-OS 20.5.1:
POD1-Leaf-1# show chassis
Chassis Name: SLX9250-32C
POD1-Leaf-1# show version
SLX-OS Operating System Version: 20.5.1
First I created 2 VRF named green and blue:
POD1-Leaf-1# conf
Entering configuration mode terminal
POD1-Leaf-1(config)# vrf green
POD1-Leaf-1(config-vrf-green)# address-family ipv4 uni
POD1-Leaf-1(config-vrf-green-ipv4-unicast)# vrf blue
POD1-Leaf-1(config-vrf-blue)# address-family ipv4 uni
I then picked two random free interfaces and configured them for VRF forwarding:
POD1-Leaf-1(config-vrf-blue-ipv4-unicast)# int e 0/9
POD1-Leaf-1(conf-if-eth-0/9)# vrf forwarding green
POD1-Leaf-1(conf-if-eth-0/9)# ip address 10.55.1.2/24
POD1-Leaf-1(conf-if-eth-0/9)# int e 0/10
POD1-Leaf-1(conf-if-eth-0/10)# vrf forwarding blue
POD1-Leaf-1(conf-if-eth-0/10)# ip address 10.50.1.2/24
POD1-Leaf-1(conf-if-eth-0/10)# end
Next I configured the basic Static Route Leaking as described in the L3 Configuration Guide:
POD1-Leaf-1(config)# vrf blue
POD1-Leaf-1(config-vrf-blue)# address-family ipv4 uni
POD1-Leaf-1(config-vrf-blue-ipv4-unicast)# ip route 10.55.2.0/24 next-hop-vrf green 10.55.1.1
POD1-Leaf-1(config-vrf-blue-ipv4-unicast)# vrf green
POD1-Leaf-1(config-vrf-green)# address-family ipv4 uni
POD1-Leaf-1(config-vrf-green-ipv4-unicast)# ip route 10.50.2.0/24 next-hop-vrf blue 10.50.1.1
POD1-Leaf-1(config-vrf-green-ipv4-unicast)# end
POD1-Leaf-1#
However I see no routes were learned:
POD1-Leaf-1# show ip route vrf green
Total number of IP routes: 0
POD1-Leaf-1# show ip route vrf blue
Total number of IP routes: 0
I found that both ports were down, so I moved the config to two ports that were free and UP:
POD1-Leaf-1# show int e 0/9
Ethernet 0/9 is up, line protocol is down (link protocol down)
POD1-Leaf-1# show int e 0/10
Ethernet 0/10 is up, line protocol is down (link protocol down)
Eth 0/15:1 connected (up) -- 25G 100G
Eth 0/15:2 connected (up) -- 25G 100G
POD1-Leaf-1# conf
Entering configuration mode terminal
POD1-Leaf-1(config)# int e 0/9
POD1-Leaf-1(conf-if-eth-0/9)# no vrf forwarding
POD1-Leaf-1(conf-if-eth-0/9)# int e 0/10
POD1-Leaf-1(conf-if-eth-0/10)# no vrf forwarding
POD1-Leaf-1(conf-if-eth-0/10)# int e 0/15:1
POD1-Leaf-1(conf-if-eth-0/15:1)# vrf forwarding green
POD1-Leaf-1(conf-if-eth-0/15:1)# ip address 10.55.1.2/24
POD1-Leaf-1(conf-if-eth-0/15:1)# no shutdown
POD1-Leaf-1(conf-if-eth-0/15:1)# int e 0/15:2
POD1-Leaf-1(conf-if-eth-0/15:2)# vrf forwarding blue
POD1-Leaf-1(conf-if-eth-0/15:2)# ip address 10.50.1.2/24
POD1-Leaf-1(conf-if-eth-0/15:2)# no shutdown
POD1-Leaf-1(conf-if-eth-0/15:2)# end
Now I see routes leaking as expected as we see the route learned from %green in blue and vice versa:
POD1-Leaf-1# show ip route vrf blue
IP Routing Table for VRF "blue"
Total number of IP routes: 3
'[x/y]' denotes [preference/metric]
10.50.1.0/24, attached
via DIRECT, Eth 0/15:2, [0/0], 0m7s, direct, tag 0
10.50.1.2/32, attached
via DIRECT, Eth 0/15:2, [0/0], 0m7s, local, tag 0
10.55.2.0/24,
via 10.55.1.1%green, Eth 0/15:1, [1/1], 0m18s, static, tag 0
POD1-Leaf-1# show ip route vrf green
IP Routing Table for VRF "green"
Total number of IP routes: 3
'[x/y]' denotes [preference/metric]
10.50.2.0/24,
via 10.50.1.1%blue, Eth 0/15:2, [1/1], 0m12s, static, tag 0
10.55.1.0/24, attached
via DIRECT, Eth 0/15:1, [0/0], 0m23s, direct, tag 0
10.55.1.2/32, attached
via DIRECT, Eth 0/15:1, [0/0], 0m23s, local, tag 0
POD1-Leaf-1#
Thanks,