Header Only - DO NOT REMOVE - Extreme Networks

How to Tag Multiple Vlan's (having different VR's) in Uplink Ports...


Userlevel 1
We are having multiple Vlan's in our Network. These Vlan's are in default VR VR-Default. Now we have created a new Vlan having different VR vr-NEW_ISP. We need to add this new vlan to our uplink ports.

While we trying to execute the following command, we are getting below error.

"configure vlan "Public" add ports 3:41 tagged"

"Error: Port 3:41 belongs to virtual router VR-Default. VLAN is created on virtual-router vr-NEW_ISP. Configuration failed on backup MM, command execution aborted!"

The issue is our uplink ports are already in multiple vlan's (having VR VR-Default).

But, We are able to do this in new uplink ports by using the following procedure. But not able to do this in the existing uplink ports.

1. Removing the new uplink port from VR-Default
2. Add the new uplink port as tagged in the new Vlan(having VR vr-NEW_ISP) .
3. Adding the uplink port as tagged in the old vlan's(having VR-Default)

To do this, we need to remove the all the existing uplink ports from VR VR-Default. These uplink ports are tagged in more than 20 numbers of Vlan's (having VR VR-Default.)

Apart from this, we are having more than 75 number of uplink ports those having 20 vlan's tagged (VR VR-Default).

Is there any possibility to add the new Vlan (VR vr-NEW_ISP) without removing the existing vlan's (having VR VR-Default)

Please help us to resolve this issue.

5 replies

Userlevel 4
I supose, you created new VR because you ran out of tags in VR-default If your vlans are transit and have the same way on your device - consider using q-in-q
Userlevel 3
Hi Thavamani,

I think that might not be possible. Please check the below link:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-make-1-port-participate-on-VLAN-s-p...

Regards,
Karthikeyan
Userlevel 4
Narayanan, Karthikeyan wrote:

Hi Thavamani,

I think that might not be possible. Please check the below link:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-make-1-port-participate-on-VLAN-s-p...

Regards,
Karthikeyan

Topicstarter asks how to avoid deleting vlans of vr-default before adding vlans of new vr
Narayanan, Karthikeyan wrote:

Hi Thavamani,

I think that might not be possible. Please check the below link:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-make-1-port-participate-on-VLAN-s-p...

Regards,
Karthikeyan

You just need to delete the port from VR-Default and then tag you vlan

Configure vr VR-Default delelete ports

Configure vlan default delete ports

configure vlan "Public" add ports 3:41 tagged

You should be good.
Userlevel 3
I ran into this same issue before, and since then we make it as a rule for new installations to remove at least all Uplinks ports, if not all ports, from VR-Default, before we add any VLAN.

To my knowledge the only way to fix this in your environment is exactly as you already realized:
- Remove all VLANs from your Uplink ports
- Remove all Uplink ports from VR-Default
- Add all VLANs again to your Uplink ports
- Then add the new VLANs that are in a different VR

I had pre-created all commands in a text-editor and then did a copy&paste via CLI - takes a second or 2 to finish it all. Just be sure you know exactly how you are connected to the switch when doing this - ideally you are in via serial console, Management port or dedicated switch port. Not through one of your Uplinks...

carsten

Reply