cancel
Showing results for 
Search instead for 
Did you mean: 

need help VDX 6740 in-band management configure

need help VDX 6740 in-band management configure

mbze430
New Contributor II

Having a bit of trouble configuring the VDX 6740 so I can access the management cli via ssh from anywhere (in-band).

My management VLAN is 100 and I figure I try to forward from the port-channel port since it's the trunk port

Here are the parts of the running-config I think is relevant:

 

interface Ve 100
ip route 10.0.253.1/24 172.30.0.1
no shutdown

rbridge-id 1
ip route 0.0.0.0/0 172.30.0.1
switch-attributes chassis-name VDX6740T-1G
switch-attributes host-name sw0
vrf mgmt-vrf
address-family ipv4 unicast
ip route 0.0.0.0/0 172.30.0.1
!
address-family ipv6 unicast
!
!
interface Management 1/0
no tcp burstrate
ip icmp echo-reply
no ip address dhcp
ip address 172.30.0.6/16
ipv6 icmpv6 echo-reply
no ipv6 address autoconfig
no ipv6 address dhcp
vrf forwarding mgmt-vrf
no shutdown

interface Port-channel 1
vlag ignore-split
speed 40000
mtu 9216
description Port Channel for Trunk to DX010
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk allowed vlan remove 1
no switchport trunk tag native-vlan
switchport trunk native-vlan 4000
no spanning-tree shutdown
no shutdown

What am I missing?  A few commands in the 7.4.0 CLI reference doesn't work either.

ex: "To disable a management VRF previously cŸnfig´r~| on a VE interface:
switch(config)# int ve 100
switch(conf-Ve-100)# no vrf forwarding mgmt-vrf"

when in the path of "conf-Ve-100" assuming the above is true, there is no option to "vrf forwarding mgmt-vrf"

Here are the only available command in "conf-Ve":

sw0(config-Ve-1)#help

Possible completions:

attach Configure attachments

describe Display transparent command information

do Run an operational-mode command

exit Exit from current mode

help Provide help information

ip The Internet Protocol (IP).

ipv6 The Internet Protocol version 6(IPv6).

no Negate a command or set its defaults

pwd Display current mode path

shutdown Shutdown the selected interface

top Exit to top level and optionally run command

sw0(config-Ve-1)# ip ?

Possible completions:

fabric-virtual-gateway IP fabric virtual gateway

 

any help to get this in-band working would be great.

 

 

1 ACCEPTED SOLUTION

Try this:

 

conf t
rb 1
vrf mgmt-vrf
address-family ipv4 unicast
ip route 0.0.0.0/0 10.0.254.1

 

Michael Morey
Principal Technical Support Engineer
Extreme Networks

View solution in original post

7 REPLIES 7

Michael_Morey
Extreme Employee

mbze430,

Your issue is that you are in the wrong context.  The VE interface you are attempting to configure is in the global config.  You need to create this interface in the RB context instead.  I would recommend you do the following:

conf t
no int ve 100
rb 1
int ve 100

and complete your configuration from there

VDX1(config-rbridge-Ve-100)# ?
Possible completions:
  bfd                   Create BFD session on this interface.
  describe              Display transparent command information
  do                    Run an operational-mode command
  exit                  Exit from current mode
  help                  Provide help information
  ip                    Internet Protocol (IP).
  ipv6                  The Internet Protocol (IP).
  no                    Negate a command or set its defaults
  pwd                   Display current mode path
  rpf-mode              Reverse Path Forwarding mode
  shutdown              Shutdown the selected interface
  snmp                  The Simple Network Management Protocol (SNMP).
  top                   Exit to top level and optionally run command
  vrf                   Assign VRF to interface
  vrrp-extended-group   Start VRRPE configuration
  vrrp-group            Start VRRP configuration
Michael Morey
Principal Technical Support Engineer
Extreme Networks

One more question.  Instead of assigning it to the portchannel, can I just assign the mgmt-vrf to a vlan?  Or it has to be assigned to a port/interface of some kind?

in my case, all the SVI vlan database is on a core L3 switch upsteam.   VLAN 100 is the management vlan with 10.0.254.0/24 range.  I should be able to assign VLAN 100 to mgmt-vrf with ip 10.0.254.6 255.255.255.0 right?  or I need to something like 'ip 10.0.254.6 255.255.255.0 vlan 100' or is it 'ip 10.0.254.6 255.255.255.0 ve 100'?  Or is it int ve 100?


int vlan 100 or (int ve 100?)
vrf forwarding mgmt-vrf
ip address 10.0.254.6 255.255.255.0

If so, do i do it in the rb 1 context or the interface context.  (I am still not used to rbridge and Ve)

 

UPDATE:

Here is what I have now, doing it in the rbridge-1 context:
!
rbridge-id 1
ip route 0.0.0.0/0 172.30.0.1
switch-attributes chassis-name VDX6740T-1G
switch-attributes host-name sw0
vrf mgmt-vrf
address-family ipv4 unicast
!
address-family ipv6 unicast
!
!
interface Ve 100
vrf forwarding mgmt-vrf
ip proxy-arp
ip address 10.0.254.6/24
no shutdown
!
!
interface Management 1/0
no tcp burstrate
ip icmp echo-reply
no ip address dhcp
ip address 172.30.0.6/16
ipv6 icmpv6 echo-reply
no ipv6 address autoconfig
no ipv6 address dhcp
vrf forwarding mgmt-vrf
no shutdown

now I can reach 10.0.254.6 and ssh in.  HOWEVER as soon as I disconnect the eth0 rj-45 cable I get cut off.... not sure why....

Adding "vrf forwarding mgmt-vrf" to VE 100 does exactly what you are asking,   Once that is configured, any port assigned VLAN 100 would be on the management VLAN.  Your current IP addressing looks fine for the VE 

ip address 10.0.254.6/24

Regarding getting cut off, if the port you are disconnecting is the only port assigned to VLAN 100, this is expected.  The VE must have at least 1 port UP/UP to be operational.

you can verify the VE status with:

show ip int bri

show ip int ve 100 rb 1

 

Michael Morey
Principal Technical Support Engineer
Extreme Networks

Okay I got a chance to play around with it more.  As of right now, I CAN get to the mgmt-vrf if I connected to any access port that is vlan 100 with an ip 10.0.254.0/24 subnet.

However, I can't get to it from another subnet.  I think it's because the Ve/mgmt-vrf isn't reporting a gateway?  I couldn't figure out how to add a gateway (10.0.254.1) to the mgmt-vrf or am I supposed to assign it to the Ve?

GTM-P2G8KFN