cancel
Showing results for 
Search instead for 
Did you mean: 

Enterasys B5g124-24p2 inter-vlan routing

Enterasys B5g124-24p2 inter-vlan routing

mt1200
New Contributor

This is what I am trying to achieve:

All networks have a subnet mask of 255.255.0.0

VLAN 2 has an ip of 10.182.xx.xx with .1.2 being the gateway (switch)

VLAN 3 has an IP of 10.164.1.1, VLAN 4 has an IP of 10.225.1.1

The Layer3 switch must redirect the traffic of VLAN2 and VLAN3 to VLAN30 which has an IP of 10.224.1.1, and VLAN4 to VLAN40 which has an IP of 10.225.1.1

I have tested using RIP and static routes which seem strange on this model because of the syntax required without success, it does not admit local interfaces as gateway IPs.

There are no external interconnections to other routers or devices. We just want the inter-vlan routing to work but it seems like there is no Enterasys equivalent of the modern “enable IP-forwarding” command.

In other words, the L3 is the only connection between hosts and it should just forward packets to the proper VLAN interface which does not seem to work ( I am testing just by pinging other VLAN IPs from a computer with VLAN02's IP as gateway address). I am attaching my config just in case.

 

Here is my config:

 

set ip protocol none
set ip address 192.168.100.254 mask 255.255.255.0

#vlan
set vlan create 2
set vlan create 3
set vlan create 4
set vlan create 5
set vlan create 30
set vlan create 40
set vlan name 1 ""
set vlan name 2 "BLS_IN_A"
set vlan name 3 "GTT_A_IN"
set vlan name 4 "GTT_B_IN"
set vlan name 5 "BLS_IN_B"
set vlan name 30 "SYSLOG_NTP_A"
set vlan name 40 "SYSLOG_NTP_B"
set vlan egress 2 ge.1.1;ge.1.3;ge.1.5 untagged
set vlan egress 3 ge.1.2;ge.1.4;ge.1.6 untagged
set vlan egress 4 ge.1.8;ge.1.10;ge.1.12 untagged
set vlan egress 5 ge.1.7;ge.1.9;ge.1.11 untagged
set vlan egress 30 ge.1.13;ge.1.15;ge.1.17 untagged
set vlan egress 40 ge.1.19;ge.1.21;ge.1.23 untagged


set port vlan ge.1.1;ge.1.3;ge.1.5 2 modify-egress
set port vlan ge.1.2;ge.1.4;ge.1.6 3 modify-egress
set port vlan ge.1.8;ge.1.10;ge.1.12 4 modify-egress
set port vlan ge.1.7;ge.1.9;ge.1.11 5 modify-egress
set port vlan  ge.1.13;ge.1.15;ge.1.17 30 modify-egress
set port vlan ge.1.19;ge.1.21;ge.1.23 40 modify-egress


#Router Configuration
router
enable
configure
interface vlan 2
ip address 10.182.1.2 255.255.0.0
ip rip enable
no shutdown
exit
interface vlan 3
ip address 10.164.1.1 255.255.0.0
ip rip enable
no shutdown
exit
interface vlan 4
ip address 10.165.1.1 255.255.0.0
ip rip enable
no shutdown
exit
interface vlan 5
exit
interface vlan 30
ip address 10.224.1.1 255.255.0.0
ip rip enable
no shutdown
exit
interface vlan 40
ip address 10.225.1.1 255.255.0.0
ip rip enable
no shutdown
exit
router rip
exit
exit
exit
exit
!

 

 

 

3 REPLIES 3

JoseQ
New Contributor

Hi @mt1200 ,

I don't believe this will be solved with static or dynamic routing, as what you're trying to do is beyond the limits of normal routing.

Normal routing is done only on basis of the destination address of the packets, not on the source address (neither the source interface).

I suggest that you try to set some kind of policy routing, maybe using VRF.

mt1200
New Contributor

It is already working, and yes, using the static routes was not the proper way since the switch "knows" how to do routing between vlans without the need to define static routes.

It was just a matter of setting up the testing environment properly.

The Enterasys for some reason will shutdown the VLAN interface if it does not detect any host connected, preventing it from showing on the IP route table. I tried pinging the VLAN interfaces from one PC but it did not work because of not having the physical connections to the corresponding networks.


Thanks

VLAN IP interface is up when at least one port has that vlan assigned, and link is UP.  For me it makes sense, because there is no need to forward packets when you don't have anything connected. It's quite normal - not only with Enterasys switches.

I stronlgy encourage you to disable RIP. If you don't have any other rip routers somewhere connected then there is no reason to use it. 

Adam

GTM-P2G8KFN