Showing results for 
Search instead for 
Did you mean: 

Problems with AdTran router and port negotiation with 670v-48t

Hello all,

Does anyone have experience with AdTran routers? I bought a NetVanta 3140 and tried to install it this morning, but I ran into some God-awful negotiation issues.

Initially I was trying to connect it to a 670v-48t running ExtremeXOS but the port kept trying to come up 100 Full Duplex. I went into the AdTran and forced the port to 1000 Full Duplex, but then I couldn't get a connection to the Extreme switch at all. On the Extreme side, I tried to set it to 1000 Full Duplex, but it wouldn't let me do that. It seems that is the expected result (you can't do that!).

* switch-core2.6 # conf port 30 auto off speed 1000 duplex fullError: Auto negotiation off is not supported on port 30 at 1G speed.
Next I tried connecting it to my Summit 450-G2 running ExtremeXOS It connected right away at 1000 Full Duplex (without having to play with the port properties). But I am dropping packets like a madman. When I tried running a 'speed test' the packet loss was just plain nasty. Even connecting to the interface and running commands seems to lag it out.

I had upgraded the firmware out of the box with the AdTran. So I tried rolling back to the factory installed OS, but I still had the same issues. Perhaps the AdTran is just 'junk'? It was rather cheap as far as routers go. If anyone has a better suggestion for which was to go with a new router - I am also taking advice. I am trying to replace an end-of-life Cisco 2801.



This has been resolved. I believe that the issue was a known bug with the firmware involving the LLDP protocol. The fix was to apply "no lldp send-and-receive" on all interfaces.

Here is a thread on the issue for anyone else that ends up in this boat.