cancel
Showing results for 
Search instead for 
Did you mean: 

About Networking Voss and Exos Systems

About Networking Voss and Exos Systems

pengguangjin999
New Contributor

pengguangjin999_0-1706930993966.png

I need to set up a network as shown in the diagram. Core is the Voss system, Access is the Exos system, and my core layer uses SPBM and VRRP technology for redundancy. The core and access are interconnected through SMLT technology. In my actual application, I found that when I disconnect an uplink, my access network is disconnected and cannot be restored until 20 packets are discarded and restored to normal. What is the reason for this?

Here is my core configuration script:


interface loopback 1
ip address 1.1.1.1/32
exit
spbm
spbm ethertype 0x8100
prompt HSBC-SZ-JF-Core_SW-001
router isis
spbm 1
spbm 1 b-vid 4051,4052 primary 4051
system-id 00bb.0021.0001
spbm 1 nick-name 1.21.01
manual-area 49.0000
spbm 1 multicast enable
spbm 1 smlt-peer-system-id 00bb.0021.0002
spbm 1 smlt-virtual-bmac 00:bb:00:21:00:0f
ip-source-address 1.1.1.1
spbm 1 ip enable
exit

vlan create 4051 type spbm-bvlan
vlan create 4052 type spbm-bvlan

vlan members remove 1 1/1-1/18
mlt 17 enable name vIST
mlt 17 member 1/17-1/18
mlt 17 encapsulation dot1q

interface mlt 17
isis
isis spbm 1
isis enable
exit

vlan create 4053 type port-mstprstp 0
vlan i-sid 4053 1004053
interface vlan 4053
ip address 10.10.0.1/30
exit
virtual-ist peer-ip 10.10.0.2 vlan 4053
cfm spbm mepid 1
cfm spbm enable
lacp smlt-sys-id 00:bb:00:21:00:ff

router isis enable

interface gig 1/17-1/18
no shutdown

vlan create 11 name WuYe_YX type port-mstprstp 0
vlan create 12 name HYS_YX type port-mstprstp 0
vlan create 13 name ****ang_YX type port-mstprstp 0

vlan i-sid 11 1000011
vlan i-sid 12 1000012
vlan i-sid 13 1000013

int vlan 11
ip address 10.0.11.253/24
ip dhcp-relay
ip vrrp version 2
ip vrrp address 11 10.0.11.254
ip vrrp 11 backup-master enable
ip vrrp 11 priority 200
ip vrrp 11 enable
ip spb-multicast enable
exit
int vlan 12
ip address 10.0.12.253/24
ip dhcp-relay
ip vrrp version 2
ip vrrp address 12 10.0.12.254
ip vrrp 12 backup-master enable
ip vrrp 12 priority 200
ip vrrp 12 enable
ip spb-multicast enable
exit
int vlan 13
ip address 10.0.13.253/24
ip dhcp-relay
ip vrrp version 2
ip vrrp address 13 10.0.13.254
ip vrrp 13 backup-master enable
ip vrrp 13 priority 200
ip vrrp 13 enable
ip spb-multicast enable
exit

mlt 1 enable name edge_B2
mlt 1 member 1/1
mlt 1 encapsulation dot1q
interface mlt 1
smlt
fa
fa enable
fa message-authentication
fa authentication-key HSBC
exit
mlt 2 enable name edge_B1
mlt 2 member 1/2
mlt 2 encapsulation dot1q
interface mlt 2
smlt
fa
fa enable
fa message-authentication
fa authentication-key HSBC
exit
mlt 3 enable name edge_1F
mlt 3 member 1/3
mlt 3 encapsulation dot1q
interface mlt 3
smlt
fa
fa enable
fa message-authentication
fa authentication-key HSBC
exit

 

The following is the configuration script I connected to:

create vlan vlan11 tag 11
create vlan vlan12 tag 12
create vlan vlan13 tag 13

configure vlan vlan11 add nsi 1000011
configure vlan vlan12 add nsi 1000012
configure vlan vlan13 add nsi 1000013

enable stpd s0 auto-bind vlan vlan11
enable stpd s0 auto-bind vlan vlan12
enable stpd s0 auto-bind vlan vlan13

enable sharing 59 grouping 59-60
configure fabric attach port 59 authentication enable
configure fabric attach ports 59 authentication key HSBC
configure fabric attach port 60 authentication enable
configure fabric attach ports 60 authentication key HSBC

configure vlan vlan11 add ports 59 tagged
configure vlan vlan12 add ports 59 tagged
configure vlan vlan13 add ports 59 tagged

configure vlan vlan11 add ports 27-44 untagged

1 ACCEPTED SOLUTION

EXTR_Paul
Extreme Employee

you should only be losing 1 ping or 3 at most. 

1- Make sure STP is disabled on your SMLT ports.

no spanning-tree mstp force-port-state enable.

2-  on your EXOS switch.  Make sure the Group algorithm is set to L2. 

https://extreme-networks.my.site.com/ExtrArticleDetail?an=000074233&q=EXOS%20shared%20group%20config...

 

3- Lastly.   SMLT from a VSP to Shared Group to EXOS is fully supported.

but for the absolute best results use LACP on the VSPs and EXOS.

VSP/VOSS example

https://extreme-networks.my.site.com/ExtrArticleDetail?an=000083501&q=VSP%20SMLT%20LACP

Then on the EXOS switch set the shared group to LACP

View solution in original post

8 REPLIES 8

EXTR_Paul
Extreme Employee

you should only be losing 1 ping or 3 at most. 

1- Make sure STP is disabled on your SMLT ports.

no spanning-tree mstp force-port-state enable.

2-  on your EXOS switch.  Make sure the Group algorithm is set to L2. 

https://extreme-networks.my.site.com/ExtrArticleDetail?an=000074233&q=EXOS%20shared%20group%20config...

 

3- Lastly.   SMLT from a VSP to Shared Group to EXOS is fully supported.

but for the absolute best results use LACP on the VSPs and EXOS.

VSP/VOSS example

https://extreme-networks.my.site.com/ExtrArticleDetail?an=000083501&q=VSP%20SMLT%20LACP

Then on the EXOS switch set the shared group to LACP

WillyHe
Contributor

Hello,

On the vIST side, the SMLT cluster switches, when SMLT is enabled on an MLT interface, spanning-tree is automatically disabled.

It is a SMLT design role to disable spanning-tree also on the other side of the connection to allow sub-second fail-over in case of link failure, when not disabled, spanning tree kicks in.

On the SMLT cluster you should use/enable SLPP (Simple Loop Prevention Protocol) which is designed to block loops in an SMLT network, on the EXOS switches SLPP-Guard is enabled on the access ports, never on the uplink ports.
Research the VOSS and EXOS manuals (and EXTREME site) for more information.

Okay, I'll give it a try.

TQU
New Contributor III

Hi Pengguangjin999,

You should check the spanning tree status on smlt interface on both side (edge and core).

From your edge configuration, I don't see any stp disable commands on sharing port.

From core config, it should be automatically disabled when it move to smlt, so no config needed.

Can you try to disable and update here ?

Regards,

Théo

GTM-P2G8KFN