cancel
Showing results for 
Search instead for 
Did you mean: 

VOSS GNS3 lab setup problem

VOSS GNS3 lab setup problem

BenT
New Contributor
Hi all

I am building a VOSS lab in GNS3 and have the following simple topology
d375f7ef77ae45fe9986607a5c36ad99.pngThere is 1 VLAN configured (VLAN 10) which should be trunked between both VSPs and then accessible from the router on Gi1/3 on VSP1

The Cisco router has a single interface with an IP 10.10.0.100

DC1-VSP1 config:

#
# CLI CONFIGURATION
#


prompt "DC1-VSP1"
password password-history 3



#
# VLAN CONFIGURATION
#

vlan members remove 1 1/1,1/3
vlan create 10 name "VLAN10" type port-mstprstp 1
vlan members 10 1/1,1/3 portmember
interface Vlan 10
ip address 10.10.0.1 255.255.255.0 0
exit

#
# PORT CONFIGURATION - PHASE I
#

interface GigabitEthernet 1/1
encapsulation dot1q

exit


#
# PORT CONFIGURATION - PHASE II
#


interface mgmtEthernet mgmt
auto-negotiate
exit
interface GigabitEthernet 1/1
default-vlan-id 0
no shutdown
exit
interface GigabitEthernet 1/3
no shutdown
exit

​

DC2-VSP2 config

#
# CLI CONFIGURATION
#


prompt "DC2-VSP1"
password password-history 3

#
# VLAN CONFIGURATION
#

vlan members remove 1 1/1
vlan create 10 name "VLAN10" type port-mstprstp 1
vlan members 10 1/1 portmember
interface Vlan 10
ip address 10.10.0.2 255.255.255.0 0
exit

#
# PORT CONFIGURATION - PHASE I
#

interface GigabitEthernet 1/1
encapsulation dot1q

exit


#
# PORT CONFIGURATION - PHASE II
#


interface mgmtEthernet mgmt
auto-negotiate
exit
interface GigabitEthernet 1/1
default-vlan-id 0
no shutdown
exit
​

I can ping from the cisco router (10.10.0.100) to DC1-VSP1 VLAN 10 IP address (10.10.0.1) but not DC2-VSP1 (10.10.0.2)

 DC1-VSP1 VLAN 10 IP address (10.10.0.1) can ping DC2-VSP1 (10.10.0.2), and vice-versa.

DC1-VSP1:1#ping 10.10.0.2
10.10.0.2 is alive

DC2-VSP1:1#ping 10.10.0.1
10.10.0.1 is alive

I am sure I have missed something obvious but I don't see it, can anyone help?

Thanks in advance
1 ACCEPTED SOLUTION

It's out now.

Starting with the 8.10.1.0 version, the hardware is based on based on 5520-24T Universal Switch. Also, in addition to control plane features, there will be limited data plane capabilities, equivalent to what is supported on ExtremeAccess Platform 1400 (XA1400).

GitHub - extremenetworks/Virtual_VOSS: VOSS VM images are provided for testing in virtual environmen...

View solution in original post

9 REPLIES 9

It's out now.

Starting with the 8.10.1.0 version, the hardware is based on based on 5520-24T Universal Switch. Also, in addition to control plane features, there will be limited data plane capabilities, equivalent to what is supported on ExtremeAccess Platform 1400 (XA1400).

GitHub - extremenetworks/Virtual_VOSS: VOSS VM images are provided for testing in virtual environmen...

mbo
New Contributor II

Thank you very much for the update! I've just run a couple of small tests and can finally use the data plane as well, this will make labs so much more efficient and realisitic!

mbo
New Contributor II

Hi everyone, I'd also be greatly interested in the version with a data plane, that would be unbelievably helpful in learning and especially testing configurations without always having to have up to date FabricEngine switches lying around in a lab.

f.e. L2 ping and L2 traceroute are working atm, but seem to be bugging around the lab, it's not working consistently (same config on all switches, some work some dont). So being able to check if a L3 ping actually gets through would be amazing.

best regards, Michael!

Anonymous
Not applicable
thanks, looking forward to it

Marlon_Scheid
New Contributor III
Hi Ben,

the VOSS GNS3 images don't have a ForwardingPlane, and without that you can not ping through the a VOSS GNS3 device.

regards
Marlon
GTM-P2G8KFN