a2h124-48 Firmware update failed CRC check all the time

  • 2
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
Hi,

i have an older a2h124-48 Switch with Firmware 02.01.01.x .
I tried to update these to 03.03.06.01 - allways with the result:

TFTP code transfer starting
Verifying CRC of file in Flash File System
Error: File failed CRC check!

Same results with Xmodem or via Netsight Inventory Manager.

So i try different Firmwares - and only 02.01.05.0001 was accepted by the A2 with Xmodem transfer.
Update Boot Code in Boot Menu didn't help.

Any Ideas?

Thanks.
Regards,
Chris
Photo of Chris Bresching

Chris Bresching

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 2
  • 1
Photo of Careno, Ryan

Careno, Ryan, Employee

  • 1,092 Points 1k badge 2x thumb
Hello Chris,

Please see the following knowledge article:

https://gtacknowledge.extremenetworks.com/articles/Solution/Error-File-failed-CRC-check-displayed-wh...

This is most likely a corrupt firmware image.  Try downloading a new copy of the A2 firmware either from your extranet account, or here's a link for A2 code 03.03.06.0001 download:

https://extremenetworks.box.com/s/1fp0v3xcifyx7cs7w7lrzexst9koe63z

Regards,
Ryan Careno
Photo of Enis V.

Enis V.

  • 60 Points
I need it, but there is no file :) Could you please put it there again ?
Photo of Janderson Mira

Janderson Mira

  • 70 Points
Please, can you guys make this file available for download.
Thanks in advanced !!!
(Edited)
Photo of Janderson Mira

Janderson Mira

  • 70 Points
No I can't, It's only available for customers with an active contract. 
Even for Legacy or discontinued products.
The link is grayed for me and the downloads counter is zeroed.
We can only download checksum file and release notes.
Photo of Eric Burke

Eric Burke

  • 3,168 Points 3k badge 2x thumb
I've seen this happen with Sonicwall firewalls.  During the download, a false positive hits a signature in IPS or AV and causes the download to stop, which in the browser looks like it was just smaller than it should have been.  Trying to upload it fails, as it's not truly the whole file.  We'd turn off IPS, GAV and MALWARE, download the file, then turn them back on (you could also create an exclusion, but we were in a hurry).  Has happened to me about a dozen times.  Not sure if it's applicable...
Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 13,220 Points 10k badge 2x thumb
Hello Chris,

you can verify the downloaded file:
  • Verify the ZIP archive. On Mac or Linux you can use "unzip -t SECURESTACK_A2-303060001-fw.zip"
  • Verify the MD5 checksum contained in the file "a-series_03_03_06_0001-MD5_Checksum.txt" (found next to the firmware download). The file contains instructions on how to create the MD5 checksum of a file. On Linux you can use "md5sum SECURESTACK_A2-303060001-fw.zip" for the archive and "md5sum a-series_03.03.06.0001" for the extracted firmware. On a Mac you can use "md5" instead of "md5sum".
This way you can verify if the download to your machine succeeded.
Photo of Chris Bresching

Chris Bresching

  • 80 Points 75 badge 2x thumb
Hello,
thanks for the answers.
the firmware works on other a2 without problems - no crc fail after tftp or xmodem transfer - so i don't believe that there are any crc errors. this is really mysterios...

is there a possibility to check the memory or repair or anything else?