Adding a multicast stream using L3

  • 0
  • 1
  • Problem
  • Updated 5 months ago
  • Not a Problem

I have added a new multicast stream , I have the server and on layer 2 I can see the correct streams , 239.192.1.56, and 239.192.2.56. on the edge device,  I have MOP configured on the vlan and on the interlink vlan on the routing points  , I have a rp configured and a cbsp both configured on our core .

There is a profile configured 224.0.0.0/4

The source address is 136.148.109.56.


From the edge I get:

224.0.0.13      136.148.109.3   4
    239.192.1.56    136.148.109.56  0
    224.0.0.252     136.148.109.84  255
    232.0.1.10      136.148.109.84  0
    232.0.1.10      136.148.109.130 0
    229.111.112.12  136.148.109.56  0
    224.0.5.128     136.148.76.52   0
    239.192.2.56    136.148.109.56  0
    239.255.255.250 10.1.10.249     0
    239.255.255.250 10.1.16.53      0

So we can see a number of streams from the 136.148.109.56 address

From the edge switch

 Slot-1 K2-SVR-SW-DS-1.1 # sh pim rp-set
Group           Mask            C-RP            Origin    Priority  Timeout
224.0.0.0       240.0.0.0       136.148.234.250 Bootstrap 75        119
Slot-1 K2-SVR-SW-DS-1.2 #

Which is understand is correct.


When looking at the core :

sh  igmp snooping vLAN xxx-CORE-RT_xxx-SVR-DS_VR-Default

Which is the point to point link between my core and edge switch


I can see


LAN xxx-CORE-RT_xxx-SVR-DS_VR-Default (xxx) Snooping=Enabled
    Group           Sender          Age
    224.0.0.5       136.148.234.162 10
    224.0.0.13      136.148.234.162 1
    224.0.5.128     136.148.76.52   0
    239.255.255.250 136.148.228.43  0
    239.255.255.250 136.148.228.45  0
    239.255.255.255 136.148.109.56  0 ( I understand this is a SAP/SNMP comms )


    6 Incoming multicast streams

    Port   Host            Subscribed        Age    Group-Limit
    1      136.148.234.162 All Groups        3      0

So my question is why cannot I see the stream on the core .

What is address 239.255.255.255 from source 136.148.109.56 ? (SAP/sNMP )

I can see the above but not the 239.192.1.56 address :(

 


136.148.109.56 is the address that I am looking for the stream from

 ( Stream address 239.192.1.56 )

So what am I missing ?







Photo of Rod Robertson

Rod Robertson

  • 2,344 Points 2k badge 2x thumb

Posted 6 months ago

  • 0
  • 1
Photo of Bastian Sprotte

Bastian Sprotte, Employee

  • 1,610 Points 1k badge 2x thumb
Hello Rob,
please check the TTL from the stream, you just trace the packets with Wireshark,
this will allow to see is the TTL will allow to route the packet.
regards
Bastian
-
Photo of Rod Robertson

Rod Robertson

  • 2,344 Points 2k badge 2x thumb

Hi Sorry for the delay , I go back out to site later this week so I can check.

Carrying on from this .

I know PIM uses the configured routing protocol , in this case OSPF.

The vlan that I have this server on is part of OSPF area 0.0.0.0 though it is configure as Passive would this have an effect on the multicast .

Sort of funny question as the SAP Multicast is getting through.


Looking forward to any suggestions




Photo of EtherMAN

EtherMAN, Embassador

  • 6,628 Points 5k badge 2x thumb
Couple of comments ... First when i see the 239.255.255.250 and 255 I am pretty certain then that is a windows box of some kind with Universal Plug and Play enabled.  It typically  uses port 1900 and can be very chatty.  

As far as the stream mcast address not showing up in the core not sure about that but as a rule it will only be learned when there is a valid client asking for the stream and the stream being forwarding across the core link and active.  
Photo of Rod Robertson

Rod Robertson

  • 2,344 Points 2k badge 2x thumb

Well Its been a few weeks now .

Returned to site to do some more investigation.

It would appear that the multicast was working for the rest of the network , just not the distribution pair of switches I was connected to , and testing on ..

So basically that's it , thanslk for all your help , I expect in my environment it will be another 5 years till I look at this again