Can't set factory default or upgrade for summit x450a-48t

  • 0
  • 1
  • Problem
  • Updated 3 weeks ago
  • Solved
Hi,

we are using summit x450a-48t with exos 15.3.2.11, recently, we want to reinstall or set factory default to it, but it didn't work.

we used command 'unconfigure switch all' and reboot, but the old configuration is still there, we also confirmed there is no default.xsf there, so we don't know how this happened.

we also tried to upgrade exos to new version, we can successfully download and install image on secondary partition, but sadly after rebooting, the active image and configuration was still old, even we used command "use image partition secondary". 

I don't know what's going on here. anybody can provide hint to solve the problem? Thanks in advance.

best regards.
Photo of Maple Wang

Maple Wang

  • 100 Points 100 badge 2x thumb

Posted 4 weeks ago

  • 0
  • 1
Photo of Alexandr P

Alexandr P, Embassador

  • 12,670 Points 10k badge 2x thumb
Hello!

Try to make upgrade EXOS from BootRom - in this case all data would be erased - https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Use-the-Boot-Rom-Menu-to-Download-a...

Also you can try to go to BootRom,
choose #config none and #boot. You will log in with default credentials (l. admin; p. none).
After log in to switch:
# clear log
# clear log counters all
# clear log messages nvram
# clear log static
# rm *.*
# rm internal memory
and then #unconfigure switch all

Thank you!
Photo of Maple Wang

Maple Wang

  • 100 Points 100 badge 2x thumb
Hi Alexandr,

unfortunately, my spacebar didn't work, I can't enter into bootrom through console, but to my surprise, your procedure in the end of reply works for me, I already set factory default for my switch, really appreciate your kind help. thanks very much.

best regards
Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 13,636 Points 10k badge 2x thumb
Hi,

the "rm *.*" part removed all scripts, not just "default.xsf". Another automatically used file is
"autoexec.xsf".

Thanks,
Erik
Photo of Maple Wang

Maple Wang

  • 100 Points 100 badge 2x thumb
Hi,

Thanks guys, but eventually, I still want to upgrade my exos, as I stated above, I can download and install exos image to second partition, but it can't take effect after reboot even I execute 'use image secondary'.

I know there is way to enter into bootrom to install image, but I can't use my spacebar through console, so is there another way to do it? force system using secondary partition anyway?

thanks again for your quick and helpful response.

best regards
Photo of Ron Huygens

Ron Huygens, Employee

  • 3,310 Points 3k badge 2x thumb
It looks like you're having an issue with the NVRAM or EEPROM. 
Open a case to have this investigated.
(Edited)
Photo of Maple Wang

Maple Wang

  • 100 Points 100 badge 2x thumb
Hi Ron,

did you mean that there is license issue? here is my switch and license type information, could you please help to check if there is something wrong? By the way, how to open a case? what information should I provide?

#show switch

System Type:      X450a-48t

SysHealth check:  Enabled (Normal)
Recovery Mode:    All
System Watchdog:  Enabled

Current Time:     Fri Sep 21 15:05:56 2018
Timezone:         [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time:        Fri Sep 21 07:51:41 2018
Boot Count:       24
Next Reboot:      None scheduled

Current State:    OPERATIONAL             
Image Selected:   primary                 
Image Booted:     primary                 
Primary ver:      15.2.3.2                
Secondary ver:    15.3.5.2

# show license
Enabled License Level:
Core
Enabled Feature Packs:
None

best regards
(Edited)
Photo of Sushruth Sathyamurthy

Sushruth Sathyamurthy, Employee

  • 966 Points 500 badge 2x thumb
Hi,

This link should help you open a case with GTAC
https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-open-GTAC-support-case-using-email

What version of EXOS are you trying to upgrade to?