Clients connecting to AP's that are too far away

  • 0
  • 1
  • Question
  • Updated 11 months ago
  • Answered
What would cause my wireless clients to overlook AP's that are close by (directly overhead) and maintain a connection to AP's that are several rooms or several floors away? I have had many issues with poor quality connections only to find that the user is nowhere near the AP they are connected to.

If I disassociate them, they will sometimes reconnect to a closer AP. But usually the reconnect to the same one. For some reason, rebooting the AP's one at a time seems to clear this up. But it continues to happen.

It also seems to happen in a pattern. We will get two to five users at once experiencing the issue.

Is this because I have the signal power set too high (I have them all set to full blast)? Or is there something else that needs tweaked?
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb

Posted 11 months ago

  • 0
  • 1
Photo of Sam

Sam, Employee

  • 1,858 Points 1k badge 2x thumb
Hi Steve,

You might find this article useful: https://gtacknowledge.extremenetworks.com/articles/Solution/Issues-with-clients-staying-with-an-Acce....

Does the issue occur mostly in 2.4GHz or 5GHz? 

- Sam  
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
Hello Sam, thanks for the link. It doesn't seem to be specific to one radio. In the past I tried forcing clients to use b/g as I assumed it was the new n/a/ac that was the issue. But that didn't make any difference. I am reluctant to make this change during production hours because I don't want to go dumping everyone off.

I did make this setting change on the one AP that I was connected to which was far away from me. It did force me to disconnect and I reconnected to the AP overhead. Hey, that worked!! However - I connected at two bars (out of five) and I was dropping packets left and right. I had 150mbps of bandwidth ... but it was useless.

Then I noticed I have some channel issues ... see my reply further down in a moment. I will put in some pictures.
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,192 Points 20k badge 2x thumb
Here is another good reference to review. Sometimes the client settings on the device can be adjusted to fix this issue as well.
 
https://gtacknowledge.extremenetworks.com/articles/Q_A/why-do-my-wireless-clients-not-roam-properly
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
I have beat my head against the wall several times on changing the roaming aggressiveness. Interestingly enough, I have had more problems with Intel dual band radios than with any other NIC. And they are usually the only one with this setting in their driver.
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
I have a lot of overlap on this network (that was my intent) but I think maybe I am choking out the channels. I followed the advice of a GTAB KB and set my Radio 1 to channel width: "80MHz". That was a mistake from what I can tell. Putting it back down to 20MHz allowed me to get connected and pass traffic again.

I presently have all my radios set to "auto" for channel assignment, but I think it may need some intervention. 

Here is a map of the area ...



And here is a sniffer screenshot. Note that in this example, I connected to the network, and walked into the next room (notice the dip on the graph). Still connected to that same AP, but with obvious drop in quality.



Note that channel overlap. Is that bad?
Photo of Sam

Sam, Employee

  • 1,858 Points 1k badge 2x thumb
Hi Steve, 

https://gtacknowledge.extremenetworks.com/articles/Q_A/What-are-the-best-radio-settings-for-my-envir... 

There looks like there is an opportunity to optimise the 2.4GHz channel plan.

It might be worth opening up a case with us here at GTAC so we can take a look into your configuration a bit further.

- Sam  
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
Thanks Sam, I just started going through that this morning. But I don't know that I made the best choices. I think I will open a GTAC case!
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 45,204 Points 20k badge 2x thumb
Hi Steve,

what is the software version, controller model, AP model and I'm very interested in the WLAN service settings.... open/none / PSK / 802.1X, TKIP or AES or both set to auto.

-Ron
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
Hello Ron,

I just upgraded to the latest, 10.31.03.0012. 

My controllers are a availability pair of C5210's. My AP's (nearly all of them) are 3825i's.

My WLAN settings are a bit of a mess. Mostly because I need to keep WPA v1 enabled to support clients that were configured for the old Cisco network. Perhaps this is part of the issue? I know it takes some fiddling with the checkboxes to allow me to use both WPA v1 and WPA v2.

(Edited)
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 45,204 Points 20k badge 2x thumb
Yes I think that could be the issue, first of all you should set it to v1 auto, v2 auto if you need both.

I had some similar issues last week after we've replaced the customers old AP26xx with AP3825 APs.
In the next weeks we'll set all his old barcode scanner from TKIP to AES so we'd remove TKIP from the wireless service.
Photo of Hawkins, Bruce

Hawkins, Bruce, Employee

  • 888 Points 500 badge 2x thumb
Ideally, you'd be using WPA2/AES exclusively if you are using encryption at all.  Enabling WPAv1 will limit your client performance (it says so right there in the red "Note" at the bottom of that screen shot) to legacy rates of 65Mbps or less and it's a less secure version of WPA that was succeeded by WPAv2 ... but if you have legacy devices that aren't WPAv2 capable ... you may need to leave both enabled. 
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
Hello Bruce. My use of WPA v1 is not compatibility. Laziness maybe?  :-) Or, lack of resources. That is, if I remove WPA v1, all of the laptops I have connected to that SSID will throw up a message that says something to the effect of "this is not the same network that it used to be".

So I plan on removing WPA v1 at some point. But since I have to touch all devices, or push out a policy of some sort, I will choose a new SSID and migrate the devices to it - then remove the old SSID once I see no activity.
Photo of Hawkins, Bruce

Hawkins, Bruce, Employee

  • 888 Points 500 badge 2x thumb
Whatever works best for you and for your environment Steve.  Just wanted to be sure you were aware of the impact of leaving WPAv1 enabled.  You likely have A/N and/or A/N/AC APs in place that are capable of delivering between 300-900Mbps for your WLAN clients depending what your configuration and physical layout involves ... and they are being constrained to performance that is magnitudes of order less than that by leaving a legacy encryption method in place which is capping them at between 54-65Mbps instead. Sounds like you're aware of all that and just need to make the choices that are best for you.  ;-)
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
I put a call into support and had them look at my maps, survey data, and of course - the settings.

He came to the conclusion that I had some definite overlapping of AP's running on the same channel. And that the signal power is way too high (cranked full). I had a bit of mis-understandings with the settings. That is, when I put channel plan to "Auto" I had thought that this meant the AP will device on what channels to run with (thinking it would make on the fly intelligent decisions). But that is not the case.

He suggested that I wait until a maintenance window and then (for both radios):
  • Set Auto Tx Power Ctrl (ATPC) = Checked/Enabled
  • Under Advanced > Dynamic Channel Selection, set from Monitor to Active Modes
  • Wait at least one hour, more if possible
  • Set Auto Tx Power Ctrl (ATPC) = Unchecked/Disabled
  • Under Advanced > Dynamic Channel Selection, set from Active to Monitor Mode
If problems persist, he also suggested that I fiddle with the settings that will force-disconnect a client who is remaining connected to a terrible connection and refusing to roam (aka Sticky clients). That is, setting "Probe Suppression" to Checked/Enabled, setting Force Disassociate to Checked/Enabled, and then changing the RSS Threshold [dBm] to somewhere around -75 (default is 90, which seems way too high ... at least in my environment).

I plan on making these changes tonight when the facility is closed and I will report my findings!
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
Following the above recommendations from support, this issue appears to be resolved. I stopped by this office this morning and did some roaming around while watching the laptop hop from one AP to another. I dropped only a small number of packets while walking at a fast past through the office several times. Now the AP's that are holding onto the largest number of radio connections are the AP's that are in the most populated areas (as it should be).

Simply put - this procedure "brought balance to the force" (in a good way, not in an Anakin Skywalker way).

I will likely repeat this same procedure at all of my other sites.
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,192 Points 20k badge 2x thumb
Great news Steve!