General question about throughput and ping ms.

  • 0
  • 1
  • Question
  • Updated 1 week ago
  • Answered
What is the normal throughput for 2.4ghz with Extreme APs and with 5 ghz? We have users complaining of slow wifi speeds and computers on the wifi are substantially slower than wired users.   Currently we are getting 35-40 mbps with iperf test when on 2.4ghz. For some reason this test could drop down to 10 on certain tests.  While on 5ghz we are right around 70mbps.  

Are these normal numbers?
Also while pinging from a wired PC to a Wireless device we will get alot of high ms pings then it will level out and then spike again.  Is this normal behavior?
Photo of Eric Ashton

Eric Ashton

  • 146 Points 100 badge 2x thumb

Posted 2 weeks ago

  • 0
  • 1
Photo of Gareth Mitchell

Gareth Mitchell, Extreme Escalation Support Engineer

  • 5,994 Points 5k badge 2x thumb
Eric

It depends on the configuration of the radios, amongst many other things.

Start here and see if this article helps you: https://gtacknowledge.extremenetworks.com/articles/How_To/How-do-I-measure-the-wireless-performance-of-a-client-on-an-access-point-and-what-factors-might-impact-performance

-Gareth
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 51,226 Points 50k badge 2x thumb
The numbers that you've posted don't look that bad to me - hard to tell with the limited information you've provided e.g. a AP models have different max. throughput

The articel that Gareth has posted is a great start - the right settings could impact the behavior a lot so check them and if you still think you didn't get the max out of the AP come back with a little bit more details about the installation.
Photo of Tomasz

Tomasz

  • 2,382 Points 2k badge 2x thumb
Amazing article, Gareth!

Remember Eric, AP throughput is not real:
- "marketing" throughput is aggregated for both radios, e.g. 1,75 Gbps for 11ac Wave 1 is 450 Mbps for 2.4 GHz and 1,3 Gbps for 5 GHz; so at best you could get 1,3 Gbps (BTW that's why some push you to buy double-port APs or 2.5 G interface switches), but...
- 802.11 MAC layer overhead, beacons and retransmissions and everything else - this reduces your throughput; it can eat about 50% of PHY throughput as mentioned (we go down to around 650 Mbps here);
- AP throughput is for full utilization of it's antennas; if the AP is 3x3:3 and your device is 2x2:2 for example, you can get two third of performance at most (despite the data rate might show some high PHY based on RF signal quality);
- same applies to channel width (20/40/80 MHz); mcsindex.com is a good point to see what PHY data rates are possible with different MIMO and channel widths for different 802.11 ammendments (then signal strength based on device sensitivity and SNR will imply actual data rate for AP-STA communication);
- in the end, all APs and STAs that talk on the same or adjacent channel interfere, so it drops your throughput even more; WiFi channel is one big collision domain with no option for collision detection so far (just CSMA/CA) so when two devices happen to talk at the same time, both might have their signals falsified.

From what you say, maybe it would be good to seek for interference (ACI/CCI) on 2.4 GHz. To many APs on the same/adjacent channel? 3rd pty SSIDs on the same/adjacent channel? Other 2.4 GHz devices with heavy blow (microwave, BT, sensors)? Too many clients on the same/adjacent channel? Perhaps the APs power is too high and with your environment they could have CCI on tens/hundreds of meters? Maybe your channel re-use plan for 2.4 GHz could be finetuned? If you are able, push dual-band clients to 5 GHz.
Those are basics, greatly enahnced within the article Gareth linked here.

Besides, IMHO AP throughput shouldn't be critical if it can reach around 20-30 Mbps per client. Unless you are doing some file transfer or multimedia streaming, typical office traffic is rather of hundreds of kbps per client on average.

My personal best so far was 200 Mbps with 2x2 Intel WLAN card on my PC (867 Mbps PHY), 11ac Wave 2 AP, 5 GHz, 5-7 meters away, conference room with small to none RF footprint around and no other clients connected. I don't remember the channel width unfortunately. I will check tomorrow in our office where I get great data rates, for the sake of curiosity.

Hope that helps,
Tomasz

(Edited)
Photo of JP

JP

  • 1,004 Points 1k badge 2x thumb
I would be curious to know more about your deployment also.  I had a similar issue with some 2.4 only clients that showed up on 3825's but not 3935's.  Basically attributed it to low end wifi cards, but would be interested to know more about your deployment. 

Photo of James A

James A, Embassador

  • 7,388 Points 5k badge 2x thumb
There is an issue with 2.4Ghz on 3825s since 10.41.07. Doing a cset factory sometimes fixes it, I'm still testing firmware for GTAC.
Photo of JP

JP

  • 1,004 Points 1k badge 2x thumb
Thanks for the info, do you see it with all 2.4 clients on 3825's ?  In my testing, not all 2.4 clients showed the behavior which is why I somewhat accepted supports determination of the card being the issue.  I have a 2.4 only laptop I use for testing and it showed the issue (very high latency with pings and dropped packets) , but a macbook air did not on 2.4  Are those the same symptoms you see ?

Also experienced the same behavior on a 3912 with the same test clients, but a 3935 was much better.  The 3912 was new out of the box, but I will try resetting a 3825 that is in use to see if it helps. 
Photo of Hawkins, Bruce

Hawkins, Bruce, Employee

  • 1,312 Points 1k badge 2x thumb
More food for thought on this subject and comparing wired vs. wireless performance:

https://gtacknowledge.extremenetworks.com/articles/Solution/Wi-Fi-Performance-Megabits-per-second-vs...
Photo of Eric Ashton

Eric Ashton

  • 146 Points 100 badge 2x thumb
Thanks for the reply everyone. As far as config goes we set our channels based on site survey so they are all staggered, sitting at 20 mhz channel width, the APs are AP3825i, latest firmware. I basically copied config from this doc. 

https://extremenetworks2com.sharepoint.com/:x:/r/sites/kcs/_layouts/15/WopiFrame.aspx?guestaccesstok...

I moved channel width to 80mhz and was able to achieve a file copy speeds of 25 - 30 mbps vs 10 -15 mbps as before on 20 mhz. Iperf3 of 84 -100mbps.   

If your saying those speeds are normal than I will focus my efforts elsewhere. Thanks
Photo of Laura

Laura

  • 1,550 Points 1k badge 2x thumb
How do i setup an iperf test? Will this measure the speed between an ipad and an access points?
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 51,004 Points 50k badge 2x thumb
One thing that I didn't mentioned... you'd also run the iperf server on a client in the LAN if you don't like to use the AP.
Photo of Laura

Laura

  • 1,550 Points 1k badge 2x thumb
I can't run iperf on a 3605 Enterasys AP? it has to be a 3900?
Photo of Laura

Laura

  • 1,550 Points 1k badge 2x thumb
Ronald,
THanks for all the help. I was able to set this is and got it working. I'm just confused about the output. You have the AP setup as the server. The 'Bandwidth' column on the screenshot from the AP is showing the speed in Mbps the AP is getting from the client device? Am I reading the output correctly? And then, the Bandwidth column on the client device is how much the client is sending to the AP?
Photo of Gareth Mitchell

Gareth Mitchell, Extreme Escalation Support Engineer

  • 5,994 Points 5k badge 2x thumb
iperf server receives traffic from the client (that is the direction of the traffic.)  So you are correct, on each device you see its perspective (which may vary especially with traffic type set to UDP.)