IPv6 address on VLAN error

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Getting error while trying to assign IPv6 interface to a vlan. IPv6 forwarding is already enabled on the VLAN, along with port tagging.

Getting error as below:-

%% Invalid input detected at '^' marker.
%% A number within the range of 1-4094 is expected.
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,518 Points 2k badge 2x thumb
Provide a command which gets an error, also would be helpful if you provide the marker '^' position of the command
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Hi Nick

Can you help with this issue?
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,518 Points 2k badge 2x thumb
I'll do my best
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Well thanks. I think it gives due to IPv6 address. Marker is shown over the address value. Not sure where I got it wrong.

"configure vlan <vlan_name_v6> ipaddress fd01:976a:c200:6f1b:0:0:1::2/127"
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,518 Points 2k badge 2x thumb
write following
configure vlan <your vlan> ip
then press TAB twice
write here what you get in help
Photo of Ron Huygens

Ron Huygens, Employee

  • 3,370 Points 3k badge 2x thumb
Hi Sumanta,

Your IPv6 notation is wrong it is now too long:
ipaddress fd01:976a:c200:6f1b:0:0:1::2/127
should be ipaddress fd01:976a:c200:6f1b::1:2/127
Photo of Balaji Kumar Navaneethapandian

Balaji Kumar Navaneethapandian, Employee

  • 260 Points 250 badge 2x thumb
Your notation is wrong because fd01:976a:c200:6f1b:0:0:1::2/127, after specifying 8 groups you are trying to specify with (::) notation before last group 2. If you try the same with fd01:976a:c200:6f1b:0:0:1:2/127 notation without :: it will work.
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Hi All

Thanks for your help. I think I figured out what else is needed. Although I changed the IPv6 address to fd01:976a:c200:6f1b:0:0:1:2/127, it gave same error.

Then I tried adding the below to the VLAN and it seems to have fixed the issue.

"eui64 fe80::/64"


configure vlan <VLAN_name_v6> ipaddress eui64 fe80::/64
configure vlan <VLAN_name_v6> ipaddress fd01:976a:c200:6f1b:0:0:2:2/127

save
Photo of David Choi

David Choi, Employee

  • 1,974 Points 1k badge 2x thumb
Hi Sumanta, What is the firmware version of your switch?
Photo of David Choi

David Choi, Employee

  • 1,974 Points 1k badge 2x thumb
In your first configuration, the IPv6 address was "fd01:976a:c200:6f1b:0:0:1::2/127". But in your second configuration, it was "fd01:976a:c200:6f1b:0:0:2:2/127".
The IPv6 address format should follow "x:x:x:x:x:x:x:x/prefix" length, where
each x is the hexadecimal value of one of the 8 16-bit pieces of the 128-bit wide
address.
The address "fd01:976a:c200:6f1b:0:0:1::2/127" means over than 8 16-bit pieces of the 128-bit.
Photo of David Choi

David Choi, Employee

  • 1,974 Points 1k badge 2x thumb
When I tested it in local, it looks there is difference per version. When I tested it with 12.4 version, there need "configure vlan <VLAN_name_v6> ipaddress eui64 fe80::/64" configuration like as you mentioned.

* BD-8810.38 # configure vlan TEST ipaddress fd01:976a:c200:6f1b:0:0:2:2/127
Error: Address must be global unicast or link-local

However it was working well with "configure vlan <VLAN_name_v6> ipaddress fd01:976a:c200:6f1b:0:0:2:2/127" in version 15.3 and 16.1 without the eui64 command.

I think there was an changes for IPv6 private address (fd01). What is the firmware version of yours?
Photo of David Choi

David Choi, Employee

  • 1,974 Points 1k badge 2x thumb
And for the following error that you mentioned in beginning:
"%% Invalid input detected at '^' marker.
%% A number within the range of 1-4094 is expected.

I believe there was some typo error or problem during transferring character. Because the error message of "the range of 1-4094" occurs when wrong like as below:

* EXSi_SW3_x460G2.10 # create vlan "TEST"
* EXSi_SW3_x460G2.13 # conf vlan "TES"
                                                                 ^
%% Invalid input detected at '^' marker.
%% A number within the range of 1-4094 is expected.
Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 13,792 Points 10k badge 2x thumb
You created a VLAN called "TEST", but then tried to configure a VLAN called "TES", which is a different name. No VLAN of that name existed. The error message tried to express this, but failed to convey the message.

Back in the day VLANs had to be referenced by name in EXOS, but now they can be referenced by name or ID, where the ID is a number between 1 and 4094.

A better error message might be "The name of a VLAN or a number within the range of 1-4094 is expected."
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Hi All

Please see below XOS version on hardware X770


21.1.2.14.
Photo of David Choi

David Choi, Employee

  • 1,974 Points 1k badge 2x thumb
Hi Sumanta,

Well, today I tested it on same model (x770-32q) and same version 21.1.2.14 but it worked well as below:

* L5:U30.10 # sh switch

SysName:          L5:U30
SysLocation:     
SysContact:       support@extremenetworks.com, +1 888 257 3000
System MAC:       00:04:96:97:89:7F
System Type:      X770-32q

SysHealth check:  Enabled (Normal)
Recovery Mode:    All
System Watchdog:  Enabled

Current Time:     Tue Nov  1 15:43:02 2016
Timezone:         [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time:        Tue Nov  1 15:35:18 2016
Boot Count:       857
Next Reboot:      None scheduled
System UpTime:    7 minutes 44 seconds

Current State:    OPERATIONAL            
Image Selected:   primary                
Image Booted:     primary                
Primary ver:      21.1.2.14              
Secondary ver:    21.1.1.4   

Config Selected:  vxlan_10112016.cfg                                  
Config Booted:    vxlan_10112016.cfg                                  

vxlan_10112016.cfg Created by ExtremeXOS version 21.1.1.4
                  561835 bytes saved on Tue Nov  1 15:20:09 2016

* L5:U30.11 # create vlan TEST
* L5:U30.12 # configure vlan TEST ipaddress fd01:976a:c200:6f1b:0:0:1:2/127
* L5:U30.13 # sh conf vlan
#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-104
configure vr VR-Default add ports 1-104
configure vlan default delete ports 1-104
create vlan "TEST"
... skipped...
configure vlan ospf_backbone ipaddress 172.168.1.1 255.255.255.248
enable ipforwarding vlan ospf_backbone
configure TEST ipaddress eui64 fe80::/64
configure TEST ipaddress fd01:976a:c200:6f1b::1:2/127
* L5:U30.14 #

The configuration was applied without any error and also without eui64 configuration.
I guess there was some problem at the time when you were executing the config.
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,676 Points 10k badge 2x thumb
Hi,

At the beginning of the thread, you were having two issues:

1) you were trying to configure a vlan that was not present (the error message was requesting a vlan id)
2) the ipv6 address format was wrong

for example, I have the same error message below, vlan "myvlan" doesn't exist on the switch.

sw1.3 # configure vlan myvlan ipaddress fd01:976a:c200:6f1b:0:0:1::2/127
%% Invalid input detected at '^' marker.
%% A number within the range of 1-4094 is expected.

As for the IPv6 address, I'd not recommend the use of /127. For links, stay with /64, it's better that way.

https://tools.ietf.org/html/rfc5375
https://tools.ietf.org/html/rfc7421
(Edited)
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Hi All

Thanks for all your support. I still don't know why it didn't let me assign IPv6 address directly. I tried multiple times, but unless I mentioned eui64 fe80::/64, it kept on giving same error.

Not sure if it is SSH terminal related issue, since I logged in via multiple nodes into the switch. Maybe something related to character recognition.

This happened in both primary as well secondary switches. However, I'll again try to assign new IPv6 address after removing the eui64 fe80::/64 part and update this thread.


Cheers,
Sumanta.
Photo of David Choi

David Choi, Employee

  • 1,970 Points 1k badge 2x thumb
If the secondary switch was also logined through multiple nodes, I would suggest to test first after connecting switch directly, not through multiple nodes. It would help to narrow down if the issue was caused by the character recognition and it would be the most simple way to test I think.