Lousy, stupid, stubborn old radiology devices (and the Summit stack that hates them)

  • 0
  • 1
  • Problem
  • Updated 2 weeks ago
Howdy folks,

I am trying to finish up a job replacing some very old Cisco 3750's with a new stack of Extreme Summit 450-G2 switches running ExtremeXOS version 22.5.1.7.

I have four devices left that are giving me problems. One of them will only connect at 100 megs HALF duplex. I know that is an issue, because the Summit will not let me force half duplex on a port. It seems I need to buy a special device from Extreme that will emulate half-duplex for old devices. That's fine!

But I have three other devices (in some way related to MRI machines) that are currently negotiating and connecting to my Cisco switch just fine at 100 megs full duplex. When I try to move them to my Extreme switch - they won't connect and work reliably.

If I do this ... "conf port 2:1 auto off speed 100 duplex full" the device will connect, but will flap. I see a flicker of a link light, and then nothing for 3 seconds or so ... then the process repeats. If I do this ... "conf port 2:1 auto on speed 100 duplex full" the device will connect at 100 megs full duplex and seems to work. However, if I run a constant ping to the device, I am dropping every 10th packet. If I plug it back into the Cisco switch, it happily connects at 100 megs Full Duplex and no packets are dropped.

I am down to a handful of these and I am hoping that the Half-Duplex to Full-Duplex Converter device fixes all my issues. But seeing how only one of these is really half-duplex, I have my doubts.

Has anyone experienced problems like this, and have an easy solution?

Another fun note - one of these devices had a home-made cable connecting it to the switch, with the strangest pin-out I have ever seen.
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,784 Points 5k badge 2x thumb

Posted 2 weeks ago

  • 0
  • 1
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,346 Points 10k badge 2x thumb
Hi,

For the 100M FD, if the devices support autoneg, they should negociate and work without any issue. Maybe their software have a buggy autoneg support? Cabling can affect things. Autoneg happens on some of the pins, so sometimes you can have autoneg working, but not data transfer.
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,784 Points 5k badge 2x thumb
Funny you should mention the cabling. The cables connecting these devices to the old switches for the past 12+ years look like utter garbage. None of the connectors are molded. So the plastic sleeve is popping out on a few. And they look like category 3 (garbage). I tried using both the old cables - and some new high grade category 6 cables. But didn't seem to make a difference. I tested them with my fluke and they all seem to check out, despite their appearance.

One of the devices had a home-made cable that was absolutely insane. It was very poorly made and was falling apart, so I put it on my cable tester, took a picture, and then made a new cable to match it.

Check out this crazy pin-out ...
1 or/wh - 8 br
2 or - 7 br/wh
3 gr/wh - 4 blue
4 blue - 5 bl/wh
5 bl/wh - 6 gr
6 gr - 3 gr/wh
7 br/wh - 2 or
8 br - 1 or/wh

^^ and this is the device that is connecting at half-duplex. I wanted to do an end-to-end test on that port just to see if someone flat out wired it wrong. But the vendor took the cable directly in to the device and wired it internally. And I am not taking a screwdriver to a nuclear medicine device.  :-)
Photo of David Coglianese

David Coglianese, Embassador

  • 6,594 Points 5k badge 2x thumb
Awe come on a nuclear medical device can cost much more than a million.

I did read an article recently about auto negotiation issues on some code but dont remember what builds were affected and am trying to find the article. I will post if I find it.
Photo of Ralf

Ralf

  • 494 Points 250 badge 2x thumb
Hi Steve,

I had some issues with older devices that want to do autoneg and only  support 100 Mbit with switches, that do autoneg and support gigabit. Best practice for that devices was, to configure the switchport, that autoneg won ́t do gigabit.

The following command will do this:

configure ports X auto on speed 100


This worked sometimes for me for devices, that use autoneg and worked with older switches and won ́t work onnew Gigabit-Switches.

Here ́s the link to the documentation:

https://documentation.extremenetworks.com/exos_22.4/EXOS_21_1/Slots_and_Ports/c_configuring-switch-p...

Best Regards, Ralf

(Edited)