Rate limit flood counters

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hi all,

I have set on my switches the rate limit for broadcast and multicast traffic to 1000 pps, i can see the Flood Rate Exceeded counter incrementing when i type the command "show port rate-limit flood refresh port-number", the configuration is also set to send a trap and log.

configure port 1:49 rate-limit flood broadcast 1000 out-actions log trap
configure port 1:49 rate-limit flood multicast 1000 out-actions log trap

My question is while the counter is incrementing i dont see any trap or log being generated. 
Photo of GONÇALO NUNO CONTENTE PIMENTEL DA SILVA REIS

Posted 2 years ago

  • 0
  • 1
Photo of Kawawa

Kawawa, GTAC

  • 3,292 Points 3k badge 2x thumb
That is by design, only the first instance of the Flood rate exceeded will trigger a log entry, all subsequent increments won't.  Imagine if your counter incremented by 10,000, your entire log would be overwritten.  You can create a script to periodically clear the rate-limit counters
Photo of Prashanth KG

Prashanth KG, Employee

  • 5,300 Points 5k badge 2x thumb
Hi,

You could try the below command which would clear the rate-limit flood status of the port. After clearing it, when the configured limit is exceeded, the log and trap would be sent.

clear ports 1:49 rate-limit flood out-of-profile status

Lab output:

Slot-1 WB-Comms.73 # clear ports 1:2 rate-limit flood out-of-profile status

SNMP stats:     InPkts 0       OutPkts   4       Errors 0       AuthErrors 0
                Gets   0       GetNexts  0       Sets   0       Drops      0
SNMP traps:     Sent   4       AuthTraps Enabled
SNMP inform:    Sent   0       Retries   0       Failed 0

Slot-1 WB-Comms.77 # sh log
03/15/2016 02:13:23.41 <Info:vlan.msgs.FldRateOutActLogEvent> Slot-1: Ingress traffic on port 1:2 exceeded a Flood Control Limit resulting in change of out-of-profile status to true.
03/15/2016 02:13:19.65 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:2 link UP at speed 1 Gbps and full-duplex
03/15/2016 02:13:03.28 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 1:2 link down

Hope this helps!
Great, Thank you for the information.