Showing results for 
Search instead for 
Did you mean: 

EMC Upgrade 8.0 - Expand disk problem

EMC Upgrade 8.0 - Expand disk problem


I just wanted to upgrade to from EMC 7.1 to EMC 8.0 and changed the VM settings with the colleagues from server according to the release-notes.
So far we had a 100 GiB disk and created a second disk with 380 GiB according to this article:

When I run the script with root-Access, the following output is logged:

This script will attempt to locate a new virtual drive and add it to
the current LVM configuration. This script will format the new drive,
and should only be used in accordance with official instructions
to increase the size of the hard drive.

Would you like to proceed? : y

Starting partition resizing. Start size is 124GB
Logging to expandLVM.log
Scanning for new partition sdc
Scan could not detect new drive sdc, exiting.
When looking at the device-files, these devices are shown:
13333 0 brw-rw---- 1 root disk 8, 0 Jul 25 10:39 /dev/sda
13337 0 brw-rw---- 1 root disk 8, 1 Jul 25 10:39 /dev/sda1
13338 0 brw-rw---- 1 root disk 8, 2 Jul 25 10:39 /dev/sda2
13339 0 brw-rw---- 1 root disk 8, 5 Jul 25 10:39 /dev/sda5
13336 0 brw-rw---- 1 root disk 8, 16 Jul 25 10:39 /dev/sdb

Can anyone give me a hint how to proceed?
Maybe the upgrade can be done with 30GiB free disk space as well?

I'm looking forward to your feedback

Best Regards


New Contributor II
the script looks for an sdc drive to expand into, but your new drive appears to be sdb
You may edit script and change all sdb entries to sda, and all sdc enties to sdb
OR you may follow the expand steps manually:

Glad I helped you

Thank you, that worked well 🙂