Showing results for 
Search instead for 
Did you mean: 

MVR doesn't work on X435

MVR doesn't work on X435

New Contributor II

Hi all!

I have one X435-24P-4S, to which I connected two PCs; on port 1 there is a sender with VLC streaming video on multicast address; on port 2, receiver with VLC listening on the same multicast address. Both have unicast IP addresses:

  • Sender:, gateway: streaming on
  • Receiver:, gateway: listening for

Multicast stream is working without a problem when hosts are placed in the same VLAN.

Now I create two VLANs:

  • "video", tag: 100, ipaddress:, with port 1 untagged
  • "workstation", tag: 200, ipaddress: with port 2 untagged

IP forwarding is enabled on both VLANs. As expected, the receiver no longer sees multicast steam.

So, to leak stream to "workstation" I configure MVR on "video":

enable mvr
configure mvr add vlan video

Reading EXOS User Guide, I understood that this should be enough to leak the stream to "workstation", but this doesn't happen. There is "mvr" entry in igmp snooping cache:

X435-24P-4S.9 # show igmp snooping cache group 
Snooping/MVR Cache Timeout: 300 sec

Type Group Sender Age InVlan

mvr 24 video
Vlan Port Vid
video 1 100
workstation 2 200

Multicast cache distribution:
3 entries from Snooping 1 entries from MVR 0 entries from PIM

Total Cache Entries: 4

but the stream doesn't hit the receiver and wireshark confirms this.

Is there something that I'm missing? I tried to configure static and dynamic MVR, but this didn't solved my problem.

Articles that I used while configuring static and dynamic MVR:


New Contributor II

Hi all!

I resolved my issue with MVR. It appears that switch with configured MVR is routing the multicast packets between VLANs, and because multicast packets had TTL set to 1, the switch was dropping them. I thought that MVR is only forcing switch to forward multicast packets between VLANs and not to route them. The solution is to set TTL of packets to something higher, for example 2.