Showing results for 
Search instead for 
Did you mean: 

ping doesn't work inter area(OSPF)

ping doesn't work inter area(OSPF)

New Contributor

I am running EXOS VM's in Oracle VirtualBox,I have a topology in this order: R1,R2 and R3. I configured OSPF in one area( and all things goes well.But when i tried to make every node in area (R1: area , R2:, R3: i could not reach the hole topology


Extreme Employee

If any of the areas cannot reach your backbone area, you can configure a virtual link. This will provide a logical path between the ABR of the disconnected area and the ABR of the normal area that connects to backbone.


configure ospf add virtual-link router-identifier area-identifier

Please review the concept guide and or the command reference guides for further information

thank you it worked 🙂

Contributor II
Hi Ala,

you need to connect every area to area for OSPF to work. As I understand your question, you connected area to and to OSPF does not support this configuration.

Best regards,

Extreme Employee
Hello Ala

The config shots you sent are very confusing. I see that you are creating VLANs which from what I can gather are part of other areas. However I don't see that all 3 of your switches are connected to area 0. In addition I don't see any of the VLANs on the same subnet so they can't talk to one another.

The design should have areas 0 connecting to all three switches on port 1 for example. You can then have a VLAN on each switch that is part of another area. So for example port 2 on Sw 1 can be in area port 2 on switch 3 can be on area If those other ports are connected to another device or the VLAN has loopback on them then those routes for those VLANs should be propagated.

Does that help?