cancel
Showing results for 
Search instead for 
Did you mean: 

Redistributing between OSPF in multiple VRF and ISIS bidirectional

Redistributing between OSPF in multiple VRF and ISIS bidirectional

PeterK
Contributor II

Hi,

I’m currently in a design process for a migration from S-Series to VSP/Fabric.

We’ve 2 S-Series (different locations) directly connected with 2 darkfiber using ospf ecmp.

We wan’t to connect 2 pairs of VSPs and having 1 S-Series to 1 VSP pair connected.

We need to implement new L2 Services across both locations.

The Plan is to have existing OSPF connections to the S-Series in VRF1 (or seperate VRFs) and all new Services including also OSPF connections in one ore more new VRFs. All should be accessable together in the first step.

 

As far as I remeber from a previous project, it’s not possible in VOSS 8.1 to redistribute between OSPF connections via ISIS, when OSPF connections are in different VRFs.

 

Does anyone know, if this is still a limitation in newer VOSS versions or having a idea for a solution?

 

thanks.

 

c8d7e26079c140a690a0a58ff5c41307_39809fb3-9118-4175-b208-e3eb28e4cc16.jpg

 

1 ACCEPTED SOLUTION

Ludovico_Steven
Extreme Employee

The limitation you mention is still there. Namely that you cannot redistribute from OSPF (VRF1) into ISIS (VRF2). And for good reason. If you started redistributing your OSPF routes into VRF2,VRF3,etc.. it becomes inefficient as the same IP routes will need to get advertised by the single Fabric ISIS instance across many different L3 I-SIDs.

The correct approach is to redistribute OSPF (VRF1) into ISIS (VRF1), i.e. same VRF. All your OSPF routes will then be in VRF1 L3VSN inside the fabric. Now if you need other fabric VRF/L3VSNs to have those routes, you simply “ISIS Accept” the routes from the VRF1 L3 I-SID, into those other VRFs.

View solution in original post

4 REPLIES 4

PeterK
Contributor II
I'm having a pretty close issue again.

I have 2 VSPs with GRT and another VRF configured.
On 1 VSP I've create route-redistribution via IPVPN from VRF to GRT.

On the 2. VSP (in GRT) I see only the directly Interfaces from 1st VSPs GRT. But I can't see the routes of the vrf.
In the isis lsdb I can see the routes.

What do I forgot?
Or is this still a limitation?

PeterK
Contributor II

Hi @Ludovico Stevens ,

I’ve done a test.

Im learning routes from a s-series via OSPF into a VRF. Redistributing via ISIS this OSPF-Routes into another VRF also works. But I didn’t get redistributing from VRF into OSPF running. I can’t see the problem. Do you have a idea?

 

sh running-config module ip
Preparing to Display Configuration...
************************************************************************************
Command Execution Time: Thu Jul 22 10:18:58 2021 UTC
************************************************************************************
#
# Thu Jul 22 10:18:58 2021 UTC
# box type : VSP-4450GSX-PWR+
# software version : 8.1.10.0
# cli mode : ECLI
#


config terminal

#
# VRF CONFIGURATION
#

ip vrf s1 vrfid 2
router vrf s1
ip ospf
exit
ip vrf sap vrfid 4

#
# IP PREFIX LIST CONFIGURATION - GlobalRouter
#

#
# IP PREFIX LIST CONFIGURATION - VRF
#

#
# IP CONFIGURATION

#

#
# IP AS LIST CONFIGURATION - GlobalRouter
#

#
# IP AS LIST CONFIGURATION - VRF
#

#
# IP COMMUNITY LIST CONFIGURATION - GlobalRouter
#

#
# IP COMMUNITY LIST CONFIGURATION - VRF
#

#
# IP EXTENDED COMMUNITY LIST CONFIGURATION - GlobalRouter
#

#
# IP EXTENDED COMMUNITY LIST CONFIGURATION - VRF
#

#
# IP ROUTE MAP CONFIGURATION - GlobalRouter
#

#
# IP ROUTE MAP CONFIGURATION - VRF
#

#
# IP CONFIGURATION - GlobalRouter
#


#
# IP CONFIGURATION - VRF
#

#
# BFD CONFIGURATION - GlobalRouter
#

#
# BFD CONFIGURATION - VRF
#

#
# CIRCUITLESS IP INTERFACE CONFIGURATION - GlobalRouter
#

#
# CIRCUITLESS IP INTERFACE CONFIGURATION - VRF
#

interface loopback 2
ip address 2 198.18.12.1/255.255.255.255 vrf s1
exit
interface loopback 3
ip address 3 198.18.14.1/255.255.255.255 vrf sap
exit

#
# TOPOLOGY-CLIP-IP
#

#
# MSDP CONFIGURATION - GlobalRouter
#

#
# VRRP CONFIGURATION - GlobalRouter
#

#
# VRRP CONFIGURATION - VRF
#

#
# UDP FORWARDING CONFIGURATION - GlobalRouter
#

#
# UDP FORWARDING CONFIGURATION - VRF
#

#
# UDP FORWARDING PORT CONFIGURATION
#

#
# UDP FORWARDING VLAN CONFIGURATION
#

#
# DHCP CONFIGURATION - GlobalRouter
#

#
# DHCP CONFIGURATION - VRF
#

#
# RIP CONFIGURATION - GlobalRouter

#

#
# RIP CONFIGURATION - VRF
#

#
# RIP VLAN CONFIGURATION
#

#
# IGMP CONFIGURATION - GlobalRouter
#

#
# IGMP CONFIGURATION - VRF
#

#
# MCAST RESOURCE USAGE CONFIGURATION - GlobalRouter
#

#
# MCAST RESOURCE USAGE CONFIGURATION - VRF
#

#
# TIMED PRUNE CONFIGURATION - GlobalRouter
#

#
# TIMED PRUNE CONFIGURATION - VRF
#

#
# RSMLT CONFIGURATION
#

#
# OSPF CONFIGURATION - GlobalRouter
#

router ospf
exit

#
# OSPF CONFIGURATION - VRF
#

router vrf s1

ip ospf admin-state
ip ospf router-id 198.18.12.1

exit

#
# OSPF ACCEPT CONFIGURATION - GlobalRouter
#

#
# OSPF ACCEPT CONFIGURATION - VRF
#

#
# BGP CONFIGURATION - GlobalRouter
#

#
# BGP CONFIGURATION - VRF
#

#
# ISIS SPBM IPVPN CONFIGURATION
#
router vrf s1
ipvpn
i-sid 3010002

ipvpn enable
exit
router vrf sap
ipvpn
i-sid 3120001
ipvpn enable
exit

#
# IP ISID LIST CONFIGURATION - GlobalRouter
#

#
# IP ISID LIST CONFIGURATION - VRF
#

#
# ISIS ACCEPT CONFIGURATION - GlobalRouter
#

#
# ISIS ACCEPT CONFIGURATION - VRF
#

router vrf s1
isis accept i-sid 3120001 enable
exit
router vrf sap
isis accept i-sid 3010002 enable
exit

#
# ISIS IPv6 ACCEPT CONFIGURATION - GlobalRouter
#


#
# ISIS IPv6 ACCEPT CONFIGURATION - VRF
#


#
# IP REDISTRIBUTION CONFIGURATION - GlobalRouter

#

router isis
redistribute direct
redistribute direct metric 1
redistribute direct enable
exit

#
# IP REDISTRIBUTION CONFIGURATION - VRF
#

router vrf s1
ip ospf redistribute isis
ip ospf redistribute isis metric-type type1
ip ospf redistribute isis enable
ip ospf redistribute direct
ip ospf redistribute direct metric-type type1
ip ospf redistribute direct enable
isis redistribute ospf
isis redistribute ospf enable
isis redistribute direct
isis redistribute direct enable

exit
router vrf sap
isis redistribute direct
isis redistribute direct enable
exit

#
# OSPF VLAN CONFIGURATION
#

#
# IPVPN CONFIGURATION
#

end

#
# IP REDISTRIBUTE APPLY CONFIGURATIONS

#
#

isis apply redistribute direct
ip ospf apply redistribute isis vrf s1
ip ospf apply redistribute direct vrf s1
isis apply redistribute ospf vrf s1
isis apply redistribute direct vrf s1
isis apply redistribute direct vrf sap

#
# IP ECMP APPLY CONFIGURATIONS


V44K-Core3:1(config)#

 

PeterK
Contributor II

Hi Ludovico,

thanks for clarification. I will test this.

Ludovico_Steven
Extreme Employee

The limitation you mention is still there. Namely that you cannot redistribute from OSPF (VRF1) into ISIS (VRF2). And for good reason. If you started redistributing your OSPF routes into VRF2,VRF3,etc.. it becomes inefficient as the same IP routes will need to get advertised by the single Fabric ISIS instance across many different L3 I-SIDs.

The correct approach is to redistribute OSPF (VRF1) into ISIS (VRF1), i.e. same VRF. All your OSPF routes will then be in VRF1 L3VSN inside the fabric. Now if you need other fabric VRF/L3VSNs to have those routes, you simply “ISIS Accept” the routes from the VRF1 L3 I-SID, into those other VRFs.

GTM-P2G8KFN