Showing results for 
Search instead for 
Did you mean: 

AP550 in boot loop

AP550 in boot loop

New Contributor

Hi, I've been out of the Aerohive world for a while and bought a couple of AP550s to use at home to get some practice with them again.

One of the APs is fine but the other is in a boot loop and the kernel is crashing and dumping a stack trace..

Loading kernel from device 0: nand0 (offset 0xf00000) ... done
Loading rootfs from device 0: nand0 (offset 0x3e00000) ... done
## Booting kernel from Legacy Image at 61005000 ...
Image Name: Linux-3.16.36
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2451489 Bytes = 2.3 MiB
Load Address: 60008000
Entry Point: 60008000
Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 62005000 ...
Image Name: uboot initramfs rootfs
Image Type: ARM Linux RAMDisk Image (uncompressed)
Data Size: 31993856 Bytes = 30.5 MiB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
Power off two PHYs...
Loading Kernel Image ... OK
boot_prep_linux commandline: root=/dev/ram console=ttyS0,9600 ramdisk_size=70000 cache-sram-size=0x10000

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
board_fixup: mem=512MB
L2C: platform provided aux values permit register corruption.
NorthStar+ >= B0 system with ACPAL disabled: subject to cache line corruption under certain conditions
NorthStar+ >= B0 system with ACPAL disabled: recommend enabling ACPAL function
Mounting local file systems...
UBI device number 0, total 3676 LEBs (933527552 bytes, 890.3 MiB), available 2043 LEBs (518823936 bytes, 494.8 MiB), LEB size 25395)
Do the DB init,please wait...
Updating system config database...
System config update complete.
kmpi: module license 'Aerohive Networks,Inc.' taints kernel.
Disabling lock debugging due to kernel taint
POE Input Detection -> AF
set attenuator GPIO e17b0780->eb7b0780
gmac_var_init: NAPI2_POLL mode
register snif device on interface eth0.
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (r659762)
register snif device on interface eth1.
eth1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (r659762)
cryp0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (r659762)

Creating fa bypass proc entry
cryp1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (r659762)
Unable to handle kernel paging request at virtual address 000026b8
pgd = da9b8000
[000026b8] *pgd=7d77d831, *pte=00000000, *ppte=00000000
Internal error: Oops: 17 [#1] PREEMPT SMP ARM
Modules linked in: wl(PO+) igs(PO) emf(PO) eth_drv(PO) ah_red(PO) ah_sec(PO) ah_board0(PO) kmpi(PO) ah_systop(O) ah_wl_shim(O)
CPU: 1 PID: 217 Comm: insmod Tainted: P O 3.16.36 #1
task: dd2f7460 ti: dc87e000 task.ti: dc87e000
PC is at awe_dos_ext_table_clean+0xc/0x1ec [wl]
LR is at awe_dos_ext_table_clean+0x194/0x1ec [wl]
pc : [<bf4b07e8>] lr : [<bf4b0970>] psr: a0000013
sp : dc87fbd0 ip : 00000000 fp : ddc11400
r10: ddc18900 r9 : bf74835c r8 : 00000001
r7 : bf748458 r6 : 00000000 r5 : ddc18900 r4 : 00000000
r3 : 000026b8 r2 : 00000000 r1 : 00000000 r0 : 00000000
Flags: NzCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment user
Control: 10c5387d Table: 7a9b804a DAC: 00000015
Process insmod (pid: 217, stack limit = 0xdc87e1b8)

Is there anything I can do about this or is it a terminal hardware issue? I tried running shmoo which I've not seen before but it doesn't seem to have helped and I don't have the password to interrupt the flash boot.





try to limit your speed on your switchport to 100mbit. Maybe cables are broken

Hi, thanks for following up. I tried slowing the port down but still see the problem.

I'm starting to think it may be hardware. I'm not sure what shmoo does but after running that the AP did connect to CloudIQ once and it said it had version 8.2 where it was 10.3 before. Since then it hasn't even booted fully again and the console stops responding. So it seems to be locked up hard.

New Contributor

Actually, it looks like I might need to flash the unit to fix it.

Can I download firmware and flash with USB thumb drive? Or do I need to get a support contract and work with support to copy via TFTP?