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K-Series with "doI2cAccess: CI2CBus::Access() failed for slave 0x40" errors

K-Series with "doI2cAccess: CI2CBus::Access() failed for slave 0x40" errors

FAQ_User
Extreme Employee
Article ID: 14197

Products
K-Series

Symptoms
Error log ('show support') contains one or more instances of "CI2CBus::Access() failed for slave 0x40" error; for example:
code:
Sep 25 23:33:06 10.18.32.1 NIM[11.tBcPoEAccs]doI2cAccess:

code:
CI2CBus::Access() failed for slave 0x40 on NIM 3#015


Power over Ethernet (PoE) may not be working on a group of ports on the referenced line card slot (NIM# + 1).

Cause
Given that "slave 0x40" refers to the PoE microcontroller and that line card slots 1-9 are identified in messages as "NIM 0" through "NIM 8", this particular message means that there is an I2C bus issue with the PoE microcontroller on the slot 4 line card.

Solution
Upgrade to firmware 7.31.03.0010 or higher.
Release notes state, in the 'Problems Corrected in 7.31.03.0010' section:
code:
POE

code:
When multiple PoE capable line cards are reset at the same time, messages similar to: "
<
code:
3
>
code:
System*11+PoE controller on Line Card 9 is not accessible." and "
<
code:
3
>
code:
NIM*11.tBcPoEAccs+doI2cAccess: CI2CBus::Access() failed for slave 0x40 on NIM 8" might be displayed. These messages are the result of PoE initialization and do not reflect loss of power on a working line card.


If the symptom persists after upgrade, please contact the GTAC for assistance.
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