Showing results for 
Search instead for 
Did you mean: 

Virtual EXOS and GNS3 - Setup Guide and Premade Projects

Virtual EXOS and GNS3 - Setup Guide and Premade Projects

Valued Contributor III
Many people have already found Virtual EXOS on GitHub. For those of you who haven’t, you’re in for a treat! Pairing GNS3 with Virtual EXOS is a great way to learn EXOS. You can easily create routable networks using just your PC – for free!

With the release of GNS3 v1.5.2, we have the ability to export full Extreme Networks projects and share them with the community. Six projects have been created and can easily be imported into GNS3.

What’s new on Extreme's Virtual EXOS repo on GitHub?
  • EXOS 22.1
  • Six pre-made portable projects that can be used with EXOS 21.1 or 22.1
  • Two guides have been updated that help with setting up Virtual EXOS in GNS3
Q & A
Ask any questions or provide feedback by commenting below, or post an issue/request on the Extreme Networks GitHub issues page.

Extreme Networks Services Team

New Contributor
Thanks Drew,
Sorry to be late to this discussion that has been closed for years. Question: ¿is there a way to set up GNS3 for the VDX switches? I specifically need the VDX switches, since their command interface is different from that of EXOS and different from VOSS. I would really appreciate if you could help me.

New Contributor
Not able to install EXOS on gns3 2.1.0:
I'm trying to install The new EXOS on gns3 version 2.1.0, I was able to installed in the 2.0 and it was running perfect, but I don't know what change in this version. (Windows 10) running gns3 on VMware Workstation 12.

I try multiple versions of the EXOS including - -

in the New Versions of gns3 and drag and drop the EXOS appliances and start the installation process, I download the EXOS version from the gns3 installation process, the .iso and the qcow2 files.

Click next until the end.

When the instalation is completed, I tried to start my SW but nothing happen, I'm not able to get any output from the console screen, or Error message. The GNS3 VM Servers Summary: CPU 0.0%, RAM 9.9%

Please advise,

Mario G.

I found the SOLUCION!!!!

I was able to import the EXOS 22.1.5. After I complete the installation under "All Devices" I found my Switch and I right click - Configure Temple - Console Type: I changed from "Telnet" to "VNC" and I was able to see the output.

It asked me to format and I chose "Y"

wait a few minutes - later ask me for AAA and I wait a few more minutes.

finally I was able to log in with "Admin" and no password needed just press enter.

any question let me know.


FYI, I had the same thing with the EXOS appliance from the GNS3 marketplace and it worked after I did what you did.

I did want to point out that if you follow the guide from the EXOS GitHub pages they point at the right qcow image that gets the switch working without that format step.

Extreme Employee
Let us know if anyone has any ideas for additional example projects!