Aastra VOIP phone and ELRP

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hi All,

We are currently struggling with an issue which appears to exist between our Extreme edge switches and certain models of VoIP phones. 

Basically, despite having ELRP configured, if a user creates a loop by plugging both the PC and LAN ports on the back of a phone into the same switch the switch does not detect it. 

We have carried out packet captures. With a laptop plugged directly into the switch, we see the ELRP packets every 2 seconds. If we put one of these phones in between (with the laptop plugged into the phones PC port) the ELRP packets do not arrive.

This suggests that the phones are stripping/filtering the packets in some way. 

Any suggestions are welcome.

Thank you,
Mykhaylo
Photo of Mykhaylo Skrypka

Mykhaylo Skrypka

  • 936 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Matthew Helm

Matthew Helm, Employee

  • 1,852 Points 1k badge 2x thumb
Do you use a separate VLAN for voice and data? if so, do you have the elrp client configured for both VLANs on the port?
Photo of Mykhaylo Skrypka

Mykhaylo Skrypka

  • 936 Points 500 badge 2x thumb
One of our senior engineers was doing troubleshooting in the lab. Results below:

As you could see from our tests in your lab , the other phones tested with ELRP operated as expected as does a direct cable loop ( using Loop vlan with all ports tagged ).

It is only the old phones 4422 that present this unexpected behaviour.

As we have already discussed ELRP uses a Multicast packet.. It would appear that the version of phone at your site , block these packets.

So we have basically 2 answers from an Extreme hardware point of view:

1:
The 4422 version of phone are being replaced, if so you could priorities those units that are connected to Extreme edge switches .

2:
Configure a basic STP configuration which as demonstrated will block the port ( led still active ) when a loop is detected .
SH STPD S0 detail , active port will be forwarding , other (looped ) port is shown as Blocked.

Thank you all for your input on this,


Mykhaylo
(Edited)
Photo of Eric Burke

Eric Burke

  • 3,288 Points 3k badge 2x thumb
Was going to suggest the same as Matthew.  ELRP is associated with one or more VLAN's.
Photo of Kevin Kim

Kevin Kim, Employee

  • 2,266 Points 2k badge 2x thumb
Storm control (flood rate-limit) would help. ('disable port' option is available in 16.1 or later)

# configure ports <port-list> rate-limit flood broadcast <pps threshold> out-actions disable-port
  <cr>            Execute the command
  log             Generate log event if traffic exceeds configured rate
  trap            Generate SNMP trap if traffic exceeds configured rate
Photo of Mykhaylo Skrypka

Mykhaylo Skrypka

  • 936 Points 500 badge 2x thumb
Hi Matthew,

Just to confirm that this configuration works fine with Aastra 6731i model.

Only Aastra 4425 or 4422 are affected.

enable elrp-client
configure elrp-client periodic B37 ports 1:1-46, 2:1-3, 2:5-40, 2:42-48, 3:1-46, 4:1-48, 5:1-5, 5:7-48 interval 2 log-and-trap disable-port duration 30
configure elrp-client periodic B37_VOIP ports 1:1-46, 2:1-3, 2:5-40, 2:42-48, 3:1-46, 4:1-48, 5:1-5, 5:7-48 interval 2 log-and-trap disable-port duration 30


Cheers,
Mykhaylo