Configuration Netflow in S-Series does NOT Work

  • 0
  • 1
  • Problem
  • Updated 4 years ago
  • Solved
This is the configuration of my S-Series, however my collector receives no information, I do not understand what the problem is.
I monitor the collector with "tcpdump port 2203" but nothing is received, however if from the S-Series run telnet to 2203 if you get it, so I discard it a problem iptables.

Any ideas?

My configuration:
# Chassis Firmware Revision:  08.11.05.0007!
# netflow
set netflow export-interval 1
set netflow export-destination 192.168.8.82 2203
set netflow export-data enable vlan
set netflow port lag.0.121 enable both
set netflow template refresh-rate 600 timeout 1
set netflow cache enable
!
end


CPD1(su)->show netflow 

Cache Status:           enabled
Export Version:               5
Export Interval:              1 (min)
Number of Entries:       6291455
Inactive Timer:              40 (sec)
Template Refresh-rate:      600 (packets)
Template Timeout:             1 (min)

Destination IP                          UDP Port
--------------------------------------- --------
10.0.0.10                                2203

               Export Rate          Max Export Rate
 Slot      (records per second)   (records per second)
-------------------------------------------------------
  2              10000                 20000
  3              10000                 20000

Enabled Ports Both Ingress and Egress:
-------------------------------------
lag.0.121

Disabled Ports:
-----------------
lag.0.1-120,122-127
ge.2.1-48,101-112,201-212
ge.3.1-48,101-112,201-212


Export Statistics:
------------------------------------
Network Packets Sampled:   285574261
Exported Packets:                  0
Exported Records:                  0
Export Packets Failed:             0
Export Records Dropped:            0
Photo of Raúl Vp

Raúl Vp

  • 80 Points 75 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Mark Lamond

Mark Lamond

  • 456 Points 250 badge 2x thumb

I have seen a similar problem.

We have a number of S series devices exporting flows successfully.

However the switch the netflow collector is attached to does not send out any flows despite all S series have an identical netflow configuration.

If i run wireshark on the collector i can see flows from all other switches, but not from the switch it is attached to.

I meant to speak to GTAC about it but have not had time yet.

Thanks,
Mark.

Photo of Raúl Vp

Raúl Vp

  • 80 Points 75 badge 2x thumb
it work!

A default interface must be configured for the records to export.

"set ip default interface vlan.0.1"

My S4 vlan.0.1 not exist, I have defined another interface and started to work.

Thanks GTAC.
(Edited)