ptpv1 messages dropped

  • 0
  • 1
  • Problem
  • Updated 1 month ago
  • Solved
We have an X460G2 (EXOS 22.4.1.4) with the network timing module included and are using the switch as a PTPv2 transparent clock.  We also have PTPv1 devices on the network for which we want the switch to forward, but for some reason they are being dropped by the switch.  Do we need an ACL to configure the forwarding of the PTPv1 messages?
Photo of Luke Bradshaw

Luke Bradshaw

  • 90 Points 75 badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of Toni Comerma

Toni Comerma

  • 230 Points 100 badge 2x thumb
PTPv1 using multicast or unicast?
Photo of Luke Bradshaw

Luke Bradshaw

  • 90 Points 75 badge 2x thumb
Multicast
Photo of Toni Comerma

Toni Comerma

  • 230 Points 100 badge 2x thumb
There is a workaround GTAC provided to us. 

entry ptp_redirect {

  if match all{

    destination-address 224.0.1.129/32 ;

  }

  then {

    redirect-vlan ;

  }

}

Please, check if PTP is using other multicast groups (depending on the domain and in use)

You must create an ACL and apply at vlan level (or affected ports)

configure access-list ptp vlan "LAWO_DANTE" ingress

Note that this broadcasts multicast traffic to all ports connected to the vlan. Bye bye igmp snooping.

On top of that, read https://extremeportal.force.com/ExtrArticleDetail?n=000022275 Multicast PTP i not supported at all.

 
Photo of Luke Bradshaw

Luke Bradshaw

  • 90 Points 75 badge 2x thumb
Thanks Toni! Works great.  I was aware of multicast PTP not being officially supported, but it does seem to work.