Remote mirroring trunk LACP

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I'm enabling remote mirroring, an LACP port sharing. 
When applying the command:

enable sharing 22 grouping 22, 24 algorithm address-based L2 lacp
configure mirror to port 22 remote-tag 1000
configure mirror add port 23 ingress-and-egress
enable mirror

not allow me to enable mirroring, giving me the error:

Error: Port mirroring cannot be enabled on a trunk member port 22

please help

Photo of Jhonn Bejar

Jhonn Bejar

  • 320 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Jason Parker

Jason Parker, Employee

  • 3,018 Points 3k badge 2x thumb
I think that you are trying to mirror a port to a lag
try these commands


enable sharing 22 grouping 22, 24 algorithm address-based L2 lacp
configure mirror to port 23 remote-tag 1000
configure mirror add port 22 ingress-and-egress                             
enable mirror


This allows you to mirror the lag(sharing port) to port 23
Photo of Jason Parker

Jason Parker, Employee

  • 3,018 Points 3k badge 2x thumb
Another

configure mirror DefaultMirror add port 24
configure mirror DefaultMirror add port 22
configure mirror DefaultMirror to port 20
enable mirror

22 and 24 are the LACP
to port 20

This is the main issue with your configuration
Note:
Error: Port mirroring cannot be enabled on a trunk member port X
Photo of Jhonn Bejar

Jhonn Bejar

  • 320 Points 250 badge 2x thumb
thanks for the reply. 
I try to enable remote mirroring as shown in the topology. 
My goal is mirroring the Port 23 (ingress and egress) of SW1 to SW3 in my Network Analyzer 

The error I get when trying to configure in SW1. 

enable sharing 22 grouping 22, 24 algorithm address-based L2 lacp
configure mirror to port 22 remote-tag 1000
configure mirror add port 23 ingress-and-egress
enable mirror

Error: Port mirroring can not be enabled on a trunk member port 22

Photo of Jason

Jason, Employee

  • 294 Points 250 badge 2x thumb
Johnn
I was also unable and here is why
You cannot mirror a Trunk port
If you want to mirror that port then remove sharing of 22 and 24
Photo of Jason

Jason, Employee

  • 294 Points 250 badge 2x thumb
Well you could enable both ports as I did above with 22 and 24
But you cannot do one port of the lacp
Photo of Jhonn Bejar

Jhonn Bejar

  • 320 Points 250 badge 2x thumb
Without sharing if it works. 
I had my production network and I can not disable sharing. 
In conclucion having sharing, remote mirroring does not work.
Photo of Derek Bird

Derek Bird, Employee

  • 576 Points 500 badge 2x thumb