cancel
Showing results for 
Search instead for 
Did you mean: 

EFA- creating L3-vlan interface

EFA- creating L3-vlan interface

MirajT
New Contributor

Hello Team,

I am new to Extreme; can anyone help to create L3-vlan interface using EFA.

I wanted to test vlan traffic coming from servers and not able to test its reaches to switch or not.

Regards,

Miraj

1 ACCEPTED SOLUTION

Michael_Morey
Extreme Employee

Miraj,

Thank you for bringing up this question.  It is actually not as straight forward as creating a VE interface on your BL and assigning it an IP.

First I am assuming that you have already registered your SLX devices within EFA, Created a CLOS 3 Fabric, and have successfully configured your fabric; Fabric Status: configure-success

In this example I have a multihomed server connected to Leaf 1 and 2 via port 0/11:1, these devices then connect to the Border Leaf devices via the Spine.

Server <> Leaf1/2 > Spine > BLeaf

First we create the Shared Tenant for the connections were your VLAN traffic will enter the Fabric via Leaf 1/2:

efa tenant create --name <Tenant_Name> --type shared --vrf-count 0 --port <Leaf1_IP>[<Ports_i.e; 0/11:1-4>],<Leaf2_IP>[<Ports_i.e; 0/11:1-4>]

*I am using a range 0/11:1-4 here for scalability 

Then we create the POs for the Southbound connections:

efa tenant po create --tenant <Shared_Tenant_Name> --name <PO_Name> --min-link-count 1 --speed 25Gbps --negotiation active --number 1 --lacp-timeout short --port <Leaf1_IP>[<Port_i.e; 0/11:1>],<Leaf2_IP>[<Port_i.e; 0/11:1>]

Then we create a Private Tenant for the Border Leaf devices:

efa tenant create --name <Private_Tenant-Name> --type private --vlan-range <Vlans_i.e; 101,102-104> --vrf-count <no_of_VRFs> --port <BLeaf1_IP>[<ports>],<BLeaf2_IP>[<ports>]

Next we create the VRF for the tenant:

efa tenant vrf create --tenant <Private_Tenant-Name> --name <VRF_Name> --routing-type centralized --centralized-router <BLeaf1_IP>,<BLeaf2_IP>

Then we create the EPG which will setup your L3 Interface:

efa tenant epg create --tenant <Private_Tenant-Name> --name <EPG_Name> --type extension --switchport-mode trunk-no-default-native --single-homed-bfd-session-type auto --po <PO_Name> --vrf <VRF_Name> --ctag-range <VLAN_Range> --anycast-ip <VLAN>:<Anycast_IP/CIDR> --local-ip <VLAN>,<BLeaf1_IP>:<Local_VE_IP/CIDR>  --local-ip <VLAN>,<BLeaf2_IP>:<Local_VE_IP/CIDR>

 

I hope this helps!

 

Michael Morey
Principal Technical Support Engineer
Extreme Networks

View solution in original post

2 REPLIES 2

Michael_Morey
Extreme Employee

Miraj,

I thought about this more this morning, and wanted to show another method in the event you only want to configure this on a single leaf switch:

First I create a Private tenant on the Leaf:

efa tenant create --name Tnt-101 --type private --vlan-range 101 --vrf-count 1 --port 10.x.x.41[0/10]

Then, create the PO:

efa tenant po create --tenant Tnt-101 --name po_101 --min-link-count 1 --speed 10Gbps --negotiation active --number 101 --lacp-timeout short --port 10.x.x.41[0/10]

Then, the VRF:

efa tenant vrf create --tenant Tnt-101 --name VR101 --routing-type distributed

And lastly the EPG:

efa tenant epg create --tenant Tnt-101 --name Epg-101 --type extension --switchport-mode trunk --po po_101 --vrf VR101 --ctag-range 101 --anycast-ip 101:10.10.10.254/24 --local-ip 101,10.x.x.41:10.10.10.1/24

 

Verification on Leaf:

Leaf-1# show run int e 0/10
interface Ethernet 0/10
description Port-channel po_101 Member interface
channel-group 101 mode active type standard
lacp timeout short
no shutdown
!
Leaf-1# show run int po 101
interface Port-channel 101
speed 10000
description EFA Port-channel po_101
cluster-track
switchport
switchport mode trunk
switchport trunk allowed vlan add 101
no switchport trunk tag native-vlan
bfd-software-session
no shutdown
!
Leaf-1# show run int ve 101
interface Ve 101
vrf forwarding VR101
ip anycast-address 10.10.10.254/24
ip address 10.10.10.1/24
no shutdown
!
Leaf-1#

 

 

Michael Morey
Principal Technical Support Engineer
Extreme Networks

Michael_Morey
Extreme Employee

Miraj,

Thank you for bringing up this question.  It is actually not as straight forward as creating a VE interface on your BL and assigning it an IP.

First I am assuming that you have already registered your SLX devices within EFA, Created a CLOS 3 Fabric, and have successfully configured your fabric; Fabric Status: configure-success

In this example I have a multihomed server connected to Leaf 1 and 2 via port 0/11:1, these devices then connect to the Border Leaf devices via the Spine.

Server <> Leaf1/2 > Spine > BLeaf

First we create the Shared Tenant for the connections were your VLAN traffic will enter the Fabric via Leaf 1/2:

efa tenant create --name <Tenant_Name> --type shared --vrf-count 0 --port <Leaf1_IP>[<Ports_i.e; 0/11:1-4>],<Leaf2_IP>[<Ports_i.e; 0/11:1-4>]

*I am using a range 0/11:1-4 here for scalability 

Then we create the POs for the Southbound connections:

efa tenant po create --tenant <Shared_Tenant_Name> --name <PO_Name> --min-link-count 1 --speed 25Gbps --negotiation active --number 1 --lacp-timeout short --port <Leaf1_IP>[<Port_i.e; 0/11:1>],<Leaf2_IP>[<Port_i.e; 0/11:1>]

Then we create a Private Tenant for the Border Leaf devices:

efa tenant create --name <Private_Tenant-Name> --type private --vlan-range <Vlans_i.e; 101,102-104> --vrf-count <no_of_VRFs> --port <BLeaf1_IP>[<ports>],<BLeaf2_IP>[<ports>]

Next we create the VRF for the tenant:

efa tenant vrf create --tenant <Private_Tenant-Name> --name <VRF_Name> --routing-type centralized --centralized-router <BLeaf1_IP>,<BLeaf2_IP>

Then we create the EPG which will setup your L3 Interface:

efa tenant epg create --tenant <Private_Tenant-Name> --name <EPG_Name> --type extension --switchport-mode trunk-no-default-native --single-homed-bfd-session-type auto --po <PO_Name> --vrf <VRF_Name> --ctag-range <VLAN_Range> --anycast-ip <VLAN>:<Anycast_IP/CIDR> --local-ip <VLAN>,<BLeaf1_IP>:<Local_VE_IP/CIDR>  --local-ip <VLAN>,<BLeaf2_IP>:<Local_VE_IP/CIDR>

 

I hope this helps!

 

Michael Morey
Principal Technical Support Engineer
Extreme Networks
GTM-P2G8KFN