cancel
Showing results for 
Search instead for 
Did you mean: 

SLX9640 LAG Config

SLX9640 LAG Config

ben645
New Contributor
Hi,

I am currently trying to setup a LAG on our SLX9640's but struggling a little. My config for my brocade is below:

lag "Netflix" dynamic id 1
ports ethernet 2/4
primary-port 2/4
lacp-timeout short
deploy
port-name "NetFlix PI" ethernet 2/4

I then have the configuration including IP address etc on the physical interface ethernet 2/4

I am trying to figure out how to this currently and believe i now need to use port-channel with Extreme. I am slightly confused as to how to create the above with extreme.

Thank you in advance.
Ben
3 REPLIES 3

Michael_Morey
Extreme Employee
For SLX, you would want to do this via a VE:

  1. Create Vlan 100 interface
code:
#vlan 100
  1. Add "router-interface Ve" for vlan 100
code:
#vlan 100
router-interface Ve 100
  1. Add "ip address 1.1.1.1/24" for Ve 100 interface
code:
#interface Ve 100
ip address 1.1.1.1/24
no shutdown
  1. Create port channel interface 100
code:
#interface Port-channel 100
  1. Add vlan 100 to port channel 100
code:
#interface port-channel 100
switchport
switchport mode trunk
switchport trunk allowed vlan add 100
switchport trunk tag native-vlan
shutdown
  1. Assign port channel 100 to the desired physical interface
code:
#interface ethernet 0/9
channel-group 100 mode active type standard
lacp timeout long
no shutdown
Michael Morey
Principal Technical Support Engineer
Extreme Networks

ben645
New Contributor
Hi Mike,

thank you for this! How do I assign an IP address to the port channel? In brocade you just put the IP details on the physical interface but I get the error trying this on extreme as it’s part of a port channel.

thank you again.
ben

Michael_Morey
Extreme Employee
Ben,

You are correct, with the SLX product we use the "Port-Channel" method of configuring LACP. This is similar to the VDX product if you are familiar with that.

First you will want to create a port channel interface:

code:
1. Enter the configure terminal command to access global configuration mode. device# configure terminal

2. Enter the "interface port-channel" command to create a new port channel interface at the global configuration level.

device(config)# interface port-channel 30

NOTE The port-channel interface ranges from 1 to 512. The example creates a new port channel interface of 30.


Then you can add member ports to the "channel-group":

code:
3. Configure the interface ethernet command to enable the interface. 

device(conf-Port-channel-30)# interface ethernet 1/5
device(conf-if-eth-1/5)#

4. Add a port to the port channel interface as static.

device(conf-if-eth-1/5)# channel-group 30 mode on

5. Or add a port to the port channel interface as a dynamic (using LACP), active or passive mode.

device(conf-if-eth-1/5)# channel-group 30 mode active
device(conf-if-eth-1/5)# channel-group 30 mode passive


I hope this helps. For more information please read up on the L2Guide for our SLX products:

https://documentation.extremenetworks.com/slxos/SW/18rx/slxr-18.1.00-l2guide.pdf

Thanks,

Mike Morey
Extreme Networks
Michael Morey
Principal Technical Support Engineer
Extreme Networks
GTM-P2G8KFN