cancel
Showing results for 
Search instead for 
Did you mean: 

VDX : communication between untagged and ctag vlan

VDX : communication between untagged and ctag vlan

eolas
New Contributor
Hello,


We would like ctag 3007 traffic from service VF 4987 to communicate with a physical server which is in untagged mode. What is the good configuration for the physical port ?

Please find the relevant snippets below :

interface Vlan 4987
spanning-tree shutdown
transport-service 987

# traffic from our customer X came with tag 3007 on port 24/0/4...
interface TenGigabitEthernet 24/0/4
mtu 9216
description trunk-port
switchport
switchport mode trunk
switchport trunk allowed vlan add 2-3,14,17-18,21,30
switchport trunk allowed vlan add 4987 ctag 3000-3200 #vlan customer X = 3007
switchport trunk tag native-vlan
qos flowcontrol tx on rx on
spanning-tree shutdown
no fabric isl enable
no fabric trunk enable
no shutdown

#physical server of our customer X in untagged mode we tried :
interface TenGigabitEthernet 112/0/42
mtu 9216
description physical server customer X
switchport
switchport mode trunk
switchport trunk native-vlan 4987 ctag 3007
switchport trunk tag native-vlan
qos flowcontrol tx on rx on
spanning-tree shutdown
no fabric isl enable
no fabric trunk enable
no shutdown


Thank you for help
2 REPLIES 2

eolas
New Contributor
Hello Mike,

We have already tried both configurations :

code:
switchport trunk native vlan [VLAN_ID] ctag [CV_ID]
no switchport trunk tag native-vlan


and
code:
switchport trunk native vlan [VLAN_ID] ctag [CV_ID]
switchport trunk tag native-vlan



without success...

regards

Michael_Morey
Extreme Employee
Eolas,

Per the NOS L2 Switching Guide, regarding Service VF and native VLAN Classifications, for Untagged traffic you will want to use the configuration on your port

code:
switchport trunk native vlan [VLAN_ID] ctag [CV_ID]
no switchport trunk tag native-vlan


There are other options as well using different modes for the switchport i.e. "no-default-native-vlan" mode. I recommend you review the Switching guide in order to decide which method works best, however with the information you have provided, you may just need to adjust the single line of config on the switchport.

I hope this helps.

Mike Morey
Michael Morey
Principal Technical Support Engineer
Extreme Networks
GTM-P2G8KFN