PV-FC-180 GRE tunnel config problem
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎03-06-2018 07:02 PM
Hello the Hub !
I need to configure PV-FC-180 to send analitycs data to PV Appliance.
I want to have a single interface configuration, where I am using two tg.1.2 and tg.1.4 interfaces configured as lag.0.1 and connected to MLAG core.
tg.1.1 is where mirrored traffic comes in (whole vlan mirror)
Here is my config (snipped - no snmp config):
configure terminal
!
interface loop.0.1
ip address 10.10.10.1 255.255.255.255 primary
exit
interface loop.0.2
ip address 10.1.103.75 255.255.255.255 primary
no shutdown
exit
interface vlan.0.1
exit
interface vlan.0.36
exit
interface vlan.0.103
ip address 10.1.103.74 255.255.255.0 primary
no shutdown
exit
interface tun.0.1
tunnel destination 10.1.103.73
tunnel mode gre l2 tbp.0.1
tunnel mirror enable
tunnel source 10.1.103.75
tunnel probe probe-name default
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 10.1.103.254 interface vlan.0.103 1
exit
!
# ip interface
set ip interface vlan.0.103 default
# netflow
set netflow export-interval 1
set netflow export-destination 10.1.103.73 2055
set netflow export-version 9
set netflow port tg.1.1 enable rx
set netflow template refresh-rate 30 timeout 1
set netflow cache enable
!
# policy
set policy profile 1 name EMC_FS_Mirror pvid-status enable pvid 0 mirror-destination 1
set policy rule admin-profile port tg.1.1 mask 16 port-string tg.1.1 admin-pid 1
!
# port
set port disable vlan.0.1,36
set port disable loop.0.1
set port jumbo enable tg.1.1
set port jumbo enable tg.1.2
set port jumbo enable tg.1.3
set port jumbo enable tg.1.4
set port lacp port tg.1.2 aadminkey 1
set port lacp port tg.1.4 aadminkey 1
set port lacp port tg.1.2 enable
set port lacp port tg.1.4 enable
set port vlan lag.0.1 103
set port vlan tg.1.2 103
set port vlan tg.1.4 103
!
!
# spantree
set spantree portadmin tg.1.2 disable
set spantree portadmin tg.1.4 disable
# ssh
set ssh enabled
!
# telnet
set telnet disable inbound
set telnet disable outbound
!
!
# vlan
set vlan create 103
set vlan name 103 servers
clear vlan egress 1 lag.0.1;tg.1.2,4
set vlan egress 103 lag.0.1;tg.1.2,4 untagged
!
#
I get no GRE traffic on my PV aplliance.
All IP's (.73 .74 .75) are reacheable.
What is wrong ?
REGARDS
Robert
I need to configure PV-FC-180 to send analitycs data to PV Appliance.
I want to have a single interface configuration, where I am using two tg.1.2 and tg.1.4 interfaces configured as lag.0.1 and connected to MLAG core.
tg.1.1 is where mirrored traffic comes in (whole vlan mirror)
Here is my config (snipped - no snmp config):
configure terminal
!
interface loop.0.1
ip address 10.10.10.1 255.255.255.255 primary
exit
interface loop.0.2
ip address 10.1.103.75 255.255.255.255 primary
no shutdown
exit
interface vlan.0.1
exit
interface vlan.0.36
exit
interface vlan.0.103
ip address 10.1.103.74 255.255.255.0 primary
no shutdown
exit
interface tun.0.1
tunnel destination 10.1.103.73
tunnel mode gre l2 tbp.0.1
tunnel mirror enable
tunnel source 10.1.103.75
tunnel probe probe-name default
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 10.1.103.254 interface vlan.0.103 1
exit
!
# ip interface
set ip interface vlan.0.103 default
# netflow
set netflow export-interval 1
set netflow export-destination 10.1.103.73 2055
set netflow export-version 9
set netflow port tg.1.1 enable rx
set netflow template refresh-rate 30 timeout 1
set netflow cache enable
!
# policy
set policy profile 1 name EMC_FS_Mirror pvid-status enable pvid 0 mirror-destination 1
set policy rule admin-profile port tg.1.1 mask 16 port-string tg.1.1 admin-pid 1
!
# port
set port disable vlan.0.1,36
set port disable loop.0.1
set port jumbo enable tg.1.1
set port jumbo enable tg.1.2
set port jumbo enable tg.1.3
set port jumbo enable tg.1.4
set port lacp port tg.1.2 aadminkey 1
set port lacp port tg.1.4 aadminkey 1
set port lacp port tg.1.2 enable
set port lacp port tg.1.4 enable
set port vlan lag.0.1 103
set port vlan tg.1.2 103
set port vlan tg.1.4 103
!
!
# spantree
set spantree portadmin tg.1.2 disable
set spantree portadmin tg.1.4 disable
# ssh
set ssh enabled
!
# telnet
set telnet disable inbound
set telnet disable outbound
!
!
# vlan
set vlan create 103
set vlan name 103 servers
clear vlan egress 1 lag.0.1;tg.1.2,4
set vlan egress 103 lag.0.1;tg.1.2,4 untagged
!
#
I get no GRE traffic on my PV aplliance.
All IP's (.73 .74 .75) are reacheable.
What is wrong ?
REGARDS
Robert
8 REPLIES 8
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎03-07-2018 07:22 AM
Thanks, Claudio - I had the lacp configured, just didn't include it in the config output:
PV-FC(su)->sh lacp lag.0.1
Global Link Aggregation state: enabled
Single Port LAGs: enabled
Aggregator: lag.0.1
Actor Partner
System Identifier: d8:84:66:4a:b5:de 02:04:96:a0:8f:39
System Priority: 32768 0
Admin Key: 1
Oper Key: 1 16
Attached Ports: tg.1.2,4
Standby Ports: None.
PV-FC(su)->sh config lacp
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
# Chassis Firmware Revision: 08.42.03.0006
!
# lacp
set lacp aadminkey lag.0.1 1
set lacp singleportlag enable
!
end
REGARDS
PV-FC(su)->sh lacp lag.0.1
Global Link Aggregation state: enabled
Single Port LAGs: enabled
Aggregator: lag.0.1
Actor Partner
System Identifier: d8:84:66:4a:b5:de 02:04:96:a0:8f:39
System Priority: 32768 0
Admin Key: 1
Oper Key: 1 16
Attached Ports: tg.1.2,4
Standby Ports: None.
PV-FC(su)->sh config lacp
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
# Chassis Firmware Revision: 08.42.03.0006
!
# lacp
set lacp aadminkey lag.0.1 1
set lacp singleportlag enable
!
end
REGARDS
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎03-07-2018 07:22 AM
Hi Robert
I think that you forgot to configure the interface lag.0.1 to agregate with the two interface tg.0.2 and tg.0.4
use this command to do so:
set lacp aadminkey lag.0.1 1
and use this other one to enable Lag port in case one interface faults:
set lacp singleportlag enable
then use this command to verify thatb the lag.0.1 is correct up
show lacp
you have to se this
->show lacp
Global Link Aggregation state: enabled
Single Port LAGs: enabled
Aggregator: lag.0.1
Actor Partner
System Identifier: 00:1F:45:2C:FC:74 02:04:96:99:B3:CF
System Priority: 32768 0
Admin Key: 10
Oper Key: 10 1004
Attached Ports: ge.1.51
ge.1.52
regards Claudio
I think that you forgot to configure the interface lag.0.1 to agregate with the two interface tg.0.2 and tg.0.4
use this command to do so:
set lacp aadminkey lag.0.1 1
and use this other one to enable Lag port in case one interface faults:
set lacp singleportlag enable
then use this command to verify thatb the lag.0.1 is correct up
show lacp
you have to se this
->show lacp
Global Link Aggregation state: enabled
Single Port LAGs: enabled
Aggregator: lag.0.1
Actor Partner
System Identifier: 00:1F:45:2C:FC:74 02:04:96:99:B3:CF
System Priority: 32768 0
Admin Key: 10
Oper Key: 10 1004
Attached Ports: ge.1.51
ge.1.52
regards Claudio
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎03-06-2018 08:08 PM
Mike - thank you so much ! Great job.
Using basic setup with no loopback interface my PV app is receiving traffic on gre interface now !
And I can see my analitycs data as well in dashboard 🙂
Using basic setup with no loopback interface my PV app is receiving traffic on gre interface now !
And I can see my analitycs data as well in dashboard 🙂
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎03-06-2018 07:40 PM
Correct. We tried to simplify it as much as possible. Your only odd part is the lag - but that is working I assume if you are able to manage the unit.