cancel
Showing results for 
Search instead for 
Did you mean: 

EXOS Switch failing Redirection/XIQ registration

EXOS Switch failing Redirection/XIQ registration

jc20
New Contributor

Hopefully this is the spot for this -

I've been through the article 000079814  and as far as I can tell - the switch can reach the internet.

The unit is an x460-G2-48p - I am reasonably certain I added the unit before getting it to properly connect... though I'm not sure if it was a virtual device or not.  I removed it while diagnosing the connection - and - well... no mas.

If I attempt to add it on the dashboard:

1522N-44253 - Device already onboarded

From the console of the switch:

X460G2-48p-10G4.1 # show iqagent
----------------------------------  --------------------------------------------
State                               Enabled
Active VR                           None
Serial Number                       1522N-44253
----------------------------------  --------------------------------------------
Status                              FAILED TO CONNECT TO REDIRECTOR/XIQ, WAITING BEFORE TRYING AGAIN
Version                             1.9.8
Debug                               ON
HTTP Proxy                          None
----------------------------------  --------------------------------------------
Association Method                  -
Association Url                     -
Poll URL                            -
----------------------------------  --------------------------------------------

Appreciate any assistance with this one -

Cheers

 

7 REPLIES 7

Good morning Bill,

I took a look at the firewall configuration again and unless the firewall should be exposing the switches ports to the internet - everything seems to be wide open. 

I did pull down the hive-agent log and this may shed some light? (excerpt from log on element that appears to repeat):

 

2025-11-09 09:33:49,434 :: 443 MOD_FSM        ah_hiveagent_fsm.c:1529:  Unable to retreive XIQ address from the CLI method
2025-11-09 09:33:49,435 :: 444 MOD_FSM        ah_hiveagent_fsm.c:1567:  Trying to get XIQ IP using DHCP method
2025-11-09 09:33:49,576 :: 445 DEVICE_RPC     rpcclt_exosDhcpGetIpString.c:28:  DHCP option 43, sub-opt 226 not present in VR-Default
2025-11-09 09:33:49,577 :: 446 MOD_FSM        ah_hiveagent_fsm.c:1574:  Unable to receive XIQ IP using DHCP method
2025-11-09 09:33:49,578 :: 447 MOD_FSM        ah_hiveagent_fsm.c:1605:  Trying to get XIQ FQDN using DHCP method
2025-11-09 09:33:49,721 :: 448 DEVICE_RPC     rpcclt_exosDhcpGetFQDN.c:28:  DHCP option 43, sub-opt 225 not present in VR-Default
2025-11-09 09:33:49,723 :: 449 MOD_FSM        ah_hiveagent_fsm.c:1611:  Unable to receive XIQ FQDN using DHCP method
2025-11-09 09:33:49,724 :: 450 MOD_FSM        ah_hiveagent_fsm.c:1640:  Trying to get XIQ address using DHCP/DNS method
2025-11-09 09:33:49,874 :: 451 DEVICE_RPC     stub_utils.c:184:  Message response code 1
2025-11-09 09:33:49,876 :: 452 DEVICE_RPC     rpcclt_exosDhcpDomainName.c:89:  No DHCP domain name
2025-11-09 09:33:49,877 :: 453 MOD_DHCP_OPT   ah_hiveagent_dhcp.c:1537:  Domain name is No DHCP domain name
2025-11-09 09:33:49,878 :: 454 MOD_UTILS      ah_hiveagent_utils.c:2264:  Invalid character in [ ]
2025-11-09 09:33:50,019 :: 455 MOD_UTILS      ah_hiveagent_utils.c:2287:  Invalid hostname to resolve [No DHCP domain name]
2025-11-09 09:33:50,021 :: 456 MOD_FSM        ah_hiveagent_fsm.c:1646:  Unable to receive XIQ address using DHCP/DNS method
2025-11-09 09:33:50,023 :: 457 MOD_FSM        ah_hiveagent_fsm.c:1677:  Trying to get XIQ URL using Redirector method
2025-11-09 09:33:50,024 :: 458 MOD_MSG_BROKER ah_hiveagent_msg_broker.c:2633:  Redirector URL is [https://hac.extremecloudiq.com/redirector/1522N-44253/hac?ver=1.9.8]
2025-11-09 09:33:50,492 :: 459 DEVICE_RPC     rpcclt_openapiDNSClientInetNameLookup.c:27:  INET lookup hac.extremecloudiq.com
2025-11-09 09:33:50,493 :: 460 DEVICE_RPC     rpcclt_openapiDNSClientInetNameLookup.c:63:  INET result 34.253.190.222
2025-11-09 09:33:50,494 :: 461 MOD_UTILS      ah_hiveagent_utils.c:2309:  Resolved Ip for [hac.extremecloudiq.com] is [34.253.190.222]
2025-11-09 09:33:50,496 :: 462 MOD_MSG_BROKER ah_hiveagent_msg_broker.c:2643:  resolved redirector url[https://hac.extremecloudiq.com/redirector/1522N-44253/hac?ver=1.9.8], domain = hac.extremecloudiq.com, ip = 34.253.190.222
2025-11-09 09:33:50,497 :: 463 MOD_HTTPS      ah_hiveagent_https_client.c:1533:  Sending Association GET Request to URL [https://hac.extremecloudiq.com/redirector/1522N-44253/hac?ver=1.9.8]
2025-11-09 09:33:50,498 :: 464 MOD_HTTPS      ah_hiveagent_https_client.c:625:  Setting CURL Header to [hac.extremecloudiq.com:443:34.253.190.222]
2025-11-09 09:33:50,499 :: 465 MOD_HTTPS      ah_hiveagent_https_client.c:671:  IQ Agent using DEFAULT interface for outgoing communication
2025-11-09 09:33:50,500 :: 466 MOD_HTTPS      ah_hiveagent_https_client.c:474:  Response = HTTP/1.1 200
2025-11-09 09:33:50,507 :: Server: nginx
2025-11-09 09:33:50,508 :: Date: Sun, 09 Nov 2025 15:33:50 GMT
2025-11-09 09:33:50,509 :: Content-Type: application/json
2025-11-09 09:33:50,510 :: Content-Length: 46
2025-11-09 09:33:50,511 :: Connection: keep-alive
2025-11-09 09:33:50,513 :: Cache-Control: no-cache, no-store, max-age=0, must-revalidate
2025-11-09 09:33:50,514 :: Pragma: no-cache
2025-11-09 09:33:50,515 :: Expires: 0
2025-11-09 09:33:50,516 :: X-XSS-Protection: 1; mode=block
2025-11-09 09:33:50,517 :: X-Frame-Options: DENY
2025-11-09 09:33:50,518 :: X-Content-Type-Options: nosniff
2025-11-09 09:33:50,520 :: Strict-Transport-Security: max-age=31536000;includeSubDomains
2025-11-09 09:33:50,521 ::
2025-11-09 09:33:50,522 ::
2025-11-09 09:33:50,523 :: 467 MOD_MSG_BROKER ah_hiveagent_msg_broker.c:2571:  Redirector provided loopback address...Ignore
2025-11-09 09:33:50,524 :: 468 MOD_MSG_BROKER ah_hiveagent_msg_broker.c:2689:  Redirector Module did not get association HMNG URL
2025-11-09 09:33:50,526 :: 469 MOD_FSM        ah_hiveagent_fsm.c:1689:  Unable to receive XIQ URL in Redirector method
2025-11-09 09:33:50,673 :: 470 MOD_FSM        ah_hiveagent_fsm.c:371:  Unable to connect to XIQ in 7 minutes
2025-11-09 09:33:52,675 :: 471 MOD_FSM        ah_hiveagent_fsm.c:376:  Association Profile: MINUTE; sleeping for 40 seconds

The first bit makes sense as DHCP is disabled.  It does appear that the redirector is resolving and at least pushing a response... the rest I can really only speculate on - but perhaps this is why we're not seeing the urls populate.  Any thoughts?

Thanks

Jc20,

I should have asked this before…. I know that earlier you mentioned that when you tried to manually onboard the device in XIQ it came up as already onboarded - is that in your XIQ instance?  Is it possible that this switch is listed in a different XIQ instance?

Also, what firmware are you running?  It may be worthwhile to upgrade to FW 32.7 code if you’re not up there already… 

I’ve seen on occasion where older code acts weirdly with XIQ.

Thanks

Bill

Presently the switch is on:

Primary ver:      33.3.1.4
                  patch1-4

So in theory we should be at least passing the bar there.

With regard to the on-boarding - just so I don't misspeak - if you mean by "your XIQ instance" we are referring to the xiq cloud instance... then I'm reasonably positive.  I have a number of APs on it already and would have noticed something awry if they were missing.  With that said - I've been into every nook and cranny of the portal and definitely haven't filtered anything... so it's definitely no longer in the inventory.  If there were logs of some form I could go back and at least make sure I didn't typo the SN and fever dream the correct one being there.  I had deleted it when troubleshooting and that's about how I landed here, hah. 

If there is a local option - I'd be happy to spin that up and see if I get the same results for diagnostic purposes?

Again - I appreciate your perseverance here.

 

 

GTM-P2G8KFN