Showing results for 
Search instead for 
Did you mean: 

Lousy, stupid, stubborn old radiology devices (and the Summit stack that hates them)

Lousy, stupid, stubborn old radiology devices (and the Summit stack that hates them)

Howdy folks,

I am trying to finish up a job replacing some very old Cisco 3750's with a new stack of Extreme Summit 450-G2 switches running ExtremeXOS version

I have four devices left that are giving me problems. One of them will only connect at 100 megs HALF duplex. I know that is an issue, because the Summit will not let me force half duplex on a port. It seems I need to buy a special device from Extreme that will emulate half-duplex for old devices. That's fine!

But I have three other devices (in some way related to MRI machines) that are currently negotiating and connecting to my Cisco switch just fine at 100 megs full duplex. When I try to move them to my Extreme switch - they won't connect and work reliably.

If I do this ... "conf port 2:1 auto off speed 100 duplex full" the device will connect, but will flap. I see a flicker of a link light, and then nothing for 3 seconds or so ... then the process repeats. If I do this ... "conf port 2:1 auto on speed 100 duplex full" the device will connect at 100 megs full duplex and seems to work. However, if I run a constant ping to the device, I am dropping every 10th packet. If I plug it back into the Cisco switch, it happily connects at 100 megs Full Duplex and no packets are dropped.

I am down to a handful of these and I am hoping that the Half-Duplex to Full-Duplex Converter device fixes all my issues. But seeing how only one of these is really half-duplex, I have my doubts.

Has anyone experienced problems like this, and have an easy solution?

Another fun note - one of these devices had a home-made cable connecting it to the switch, with the strangest pin-out I have ever seen.

Valued Contributor III
Hi Steve,
Were you able to get this one sorted out?

Hi Drew, I have one of those "half-duplex converters" on order at the moment. I am thinking that will clear up these issues.

New Contributor II
Hi Steve,

I had some issues with older devices that want to do autoneg and only support 100 Mbit with switches, that do autoneg and support gigabit. Best practice for that devices was, to configure the switchport, that autoneg won ́t do gigabit.

The following command will do this:

configure ports X auto on speed 100

This worked sometimes for me for devices, that use autoneg and worked with older switches and won ́t work onnew Gigabit-Switches.

Here ́s the link to the documentation:

Best Regards, Ralf

Extreme Employee
Hi, For the 100M FD, if the devices support autoneg, they should negociate and work without any issue. Maybe their software have a buggy autoneg support? Cabling can affect things. Autoneg happens on some of the pins, so sometimes you can have autoneg working, but not data transfer.