Showing results for 
Search instead for 
Did you mean: 

OSPF routing between EXOS and VSP switches

OSPF routing between EXOS and VSP switches

Contributor II
Hi Community

I am new to the VSP series switch.

In my Lab I am trying to configure OSPF routing between a x460-G2 and a VSP4850.
The x460-g2 is loaded with a core license and the VSP4850 is loaded with the premier license.

The network diagram looks as follows:


I have a client vlan create on the x460 and another client vlan on the VSP4850.
I have configured ospf as I would expect it to be but I am having problems.

The ospf neighbor ship is formed and a full adjacency is formed.
If I look at the routing table on the VSP is see all the directly connected routes and I see the OSPF routes for and

So the x460 is advertising the routes to the VSP as expected.

However if I look at the routing table on the x460 I only see the direct connected routes.
I do not see the client vlan on the VSP advertised via ospf.

The config on x460 looks as follows:

create vlan LoopBack1 tag 111 description LoopBack
configure vlan LoopBack1 ipaddress
enable loopback
enable loopback-mode LoopBack1

create vlan 200
configure vlan 200 ipaddress
enable ipforwarding
configure vlan Default delete ports 48
configure vlan 200 add ports 48 untagged

configure ospf routerid
configure ospf add VLAN_0200 area link-type point-to-point
configure ospf add LoopBack1 area
enable ospf

create vlan Client_Data tag 100
configure vlan 100 add ports 1 tagged
configure vlan 100 ipaddress
configure ospf add VLAN_100 area passive

The questions is what should the OSPF config on the VSP side be then?


Contributor II
Hi Roy

I tested the above but still no routes on the x440.

Actually my LAB is slightly more complex.
With my first post I tried to simply the issue but here goes.

I have a client VRF created on the VSP 4850.
This VRF should route via OSPF between the client network (X440) and the VSP

The config on the VSP looks as follows:

Remember that the OSPF Neighbor relationship is fully formed and the VSP's are receiving the routes from the X440, the only thing is that the x440 does not receive any routes from the VSP.

router vrf clienta_l3vpn
ip ospf router-id
ip ospf
ip ospf admin-state


interface Vlan 200
vrf clienta_l3vpn
ip ospf enable

interface Vlan 222
vrf clienta_l3vpn
ip ospf enable

Extreme Employee
Hi Andre,

Since OSPF config of VSP side is not attached, I can't be sure what is causing this.
But if you have redistributed direct connected network(client VLAN), the VSP should declare itself as an ASBR.
EXOS makes itself as an ASBR automatically when it redistribute any route entries but VSP needs the below command.

VSP-8404:1(config)#router ospf
VSP-8404:1(config-ospf)#as-boundary-router enable

If this is not a case, post the config of VSP to so that we can check what are missing here.