Showing results for 
Search instead for 
Did you mean: 

OSPF routing between EXOS and VSP switches

OSPF routing between EXOS and VSP switches

Contributor II
Hi Community

I am new to the VSP series switch.

In my Lab I am trying to configure OSPF routing between a x460-G2 and a VSP4850.
The x460-g2 is loaded with a core license and the VSP4850 is loaded with the premier license.

The network diagram looks as follows:


I have a client vlan create on the x460 and another client vlan on the VSP4850.
I have configured ospf as I would expect it to be but I am having problems.

The ospf neighbor ship is formed and a full adjacency is formed.
If I look at the routing table on the VSP is see all the directly connected routes and I see the OSPF routes for and

So the x460 is advertising the routes to the VSP as expected.

However if I look at the routing table on the x460 I only see the direct connected routes.
I do not see the client vlan on the VSP advertised via ospf.

The config on x460 looks as follows:

create vlan LoopBack1 tag 111 description LoopBack
configure vlan LoopBack1 ipaddress
enable loopback
enable loopback-mode LoopBack1

create vlan 200
configure vlan 200 ipaddress
enable ipforwarding
configure vlan Default delete ports 48
configure vlan 200 add ports 48 untagged

configure ospf routerid
configure ospf add VLAN_0200 area link-type point-to-point
configure ospf add LoopBack1 area
enable ospf

create vlan Client_Data tag 100
configure vlan 100 add ports 1 tagged
configure vlan 100 ipaddress
configure ospf add VLAN_100 area passive

The questions is what should the OSPF config on the VSP side be then?


Extreme Employee
Hello Andre,

If you have configured as-boundary-router enabled and ospf redistribution as you described, I think configuration parts should be no problem.
How about LSDB on both X440 and VSP?
Do you see any redistributed route entries as type 5 LSAs?

Contributor II

I have tried the following but the routes form the across the fabric is still not shared via OSPF to an extrenal x440:

ip ospf redistribute isis
ip ospf redistribute isis metric 1
ip ospf redistribute isis enable

ip ospf apply redistribute vrf clienta_l3vpn

Still none of the ISIS routes learned across the fabric is redistributed into OSPF

Contributor II
Hi Jongseok

Thank you that seemed to resolve my issue.
Routes are now learned on both the VSP and the x440.

I am adding some more complexity.

I am extending this VRF on the VSP switch arcoss a fabric to another VSP.
The L3VSN is working. (I followed the config guide)
If I look at the remote VSP I see all the routes from the first VSP that is also running the OSPF to the x440.
The remote VSP is also receiving the OSPF routes that was advertised from the x440.
However the x440 is not learning the routes from the remote VSP switch,
I would presume that I will need to redistribute ISIS routes (Learned within the L3VSN) to OSPF.
I have tested various of the "ip ospf redist isis" commands but can not seem to get it to go.

What would the commands then be to redistribute the L3VSN routes learned via ISIS to the OSPF X440?

Extreme Employee
Hi Andre,

I found OSPF link type on vlan 200 is point-to-point on Exos side as below.

configure ospf add VLAN_0200 area link-type point-to-point

Currently, any of legacy Avaya switch does not support point-to-point. Default type is Broadcast.
Thus, change the link-type of Exos as Broadcast and see the OSPF routing entries.