Showing results for 
Search instead for 
Did you mean: 

Will the basic xsf script used with EXOS 22.7x work without issue on EXOS 3x.x?

Will the basic xsf script used with EXOS 22.7x work without issue on EXOS 3x.x?

New Contributor
I am in the process of deploying some new test bench switches X4460G2 and I had an issue with original script I had but it came from from EXOS 15 and it kept throwing script errors, the errors seemed more to do with the scripting then the actual EXOS commands.  So I was thinking I would try tweaking my XSF script from our X460g2 stacks, but without the stacking aspect.  I was wondering how much pain I might experience using a EXOS22.7 script with EXOS 30+. As I have not been able to find a script template that is specific to EXOS 30+.

I do have siteiq, but trying to configure the basic switch from there has proved difficult as I have not been able to skip fields, it wants something in everyone and then times out, not to mention I have to configure the basic IP info before I can work with it from Siteiq.  But I have not found the out of box configuration scripts in it to suit my needs it not a mass deployment, 3 individual switches with the only difference being the assigned IP.

Its just basic stuff like IP, routing, several vlans, qos profiles, security/ssh settings, snmpv3 (Siteiq).

Extreme Employee
Hi Joe,

Do you mean like removing the stacking nomenclature("1" vs "1:1"  Do you know what commands it was tripping over previously?

Chris Thompson

I am reviewing my logs now to try and better explain it.

New Contributor
These type of statements:
set var snmpadminpass
set var snmpinitialmd5Privpass

even thought he variables had the contents the script choked on setting a bunch of them, it kept saying incomplete command line yada yada but if I run the command with the contents of the variable manually it the command works just fine which leads me back to a possible issue with the script flow.

The original script as download from extreme also had some logging stuff enabled which cause aborting so I removed the logging options but left the abort on error enabled.  It got most of the way through the script before it aborted again from reviewing y logs I eventually got one to run completely after doing unconfigure and but then it appeared things were 100% set correctly as my logs indicated I went back and manually set a bunch of stuff. 

It was not tripping over EXOS commands but scripting commands, I am referring to scripting statements .  The script I original tried did not have any stacking aspects in it.  I have to review my putty logs to get the exact items it had issue with, as it has been little while since I ran it. I jus got back around to revisiting this.