Showing results for 
Search instead for 
Did you mean: 

x460-48p (gen1) with v.80 stacking - can't get it to work when replacing a device

x460-48p (gen1) with v.80 stacking - can't get it to work when replacing a device

New Contributor III
We have a stack of x460-48p (gen 1 NOT gen 2) running code patch 1-3. We had one slot reboot periodically (had tried replacing the power supply, power cable, stacking module and stacking cables) but it still reboots. So today we replaced the unit with a spare from stock and plan to RMA the defective. We got the code and partition setup properly (we have lots of practice with this exercise...... hooked up the replacement to the stack, but it won't join the stack so that we could give it a number and join the group. When we do show stacking on the existing stack, the new mac never shows up in any way. We tried unconfiguring switch all on the replacement switch and rebooting and even replaced the stacking module thinking maybe something was wacky with that. The code and partition is correct, there are no core licenses causing issues. The only thing that looks different with the replacement switch is the bootrom, it's newer at versus the existing stack at Could that be the cause of our issue? We had to get the switch band-aid connected b/c school day was starting so I wanted to see if there are any ideas that we can try to get it properly setup. There were no error messages on either the existing stack or the replacement device. And as mentioned we replace defective devices all the time so this is a head scratcher. Thanks in advance for ideas.


New Contributor III
The replacement was brand new and we tried unconfigure stacking all when we ran in to problems.
Ended up rebooting the entire stack, then the replacement showed up with show stacking and could be properly added to the stack. Guess it's cliche a reboot but it does solve many problems haha
Thanks for the ideas

Extreme Employee
Was the replacement unit in another stack in the past (production, lab, testing...)? If so, make sure there's no leftover (disable stacking, disable stacking-support, unconfig sw all...), otherwise that will cause an issue. Did you look at the logs on the Master, when you tried to add that unit? Sometimes it gives you the answer. You said license was good (no Core): sure there's no difference? No Feature Pack nor Trial on the new switch? Did you enabled stacking-support (as you need to do V80)?

Can you send a "show stacking detail" from the master?

New Contributor III

I tried what you recommended looks like I have to hit enter after native, it wouldn't take any variation of v80 or anything at the end
X460-48p.3 # conf stacking-support stack-ports all selection native v80
%% Invalid input detected at '^' marker.

So the command conf stacking-support stack-ports all selection native took and I rebooted the new switch, it doesn't seem to have made a change....

Thanks for the suggestion