cancel
Showing results for 
Search instead for 
Did you mean: 

dhcp ip allocation for particular vlan

dhcp ip allocation for particular vlan

sumeet
New Contributor
hi , we have extreme networks summit x460-24t switch . I want to do the following
switch should assign ip to dhcp client for particular vlan . All packet IP's unknown to switch should be passed from port 1 .

example in cisco we had

ip dhcp pool vlan200
network 172.16.120.0 255.255.255.0
dns-server 196.1.105.47
default-router 172.16.120.1
lease infinite
!
interface Vlan34
ip address 192.168.0.11 255.255.255.0
!
interface GigabitEthernet0/1
switchport access vlan 34
mls qos vlan-based
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1

I tried following in extreme

create vlan "vlan200"
configure vlan vlan131 tag 200
configure vlan vlan200 ipaddress 10.10.10.1 255.255.255.0
configure vlan vlan200 dhcp-address-range 10.10.10.2 - 10.10.10.10

Where am I going wrong ?
15 REPLIES 15

sumeet
New Contributor
I thought i just have to add tagged while adding vlan to particular port if I want tagged input/output from port of switch . I hope , dhcp , ip address etc. parameters will remain same .
example
configure vlan "vlan34" add ports 11
becomes
configure vlan "vlan34" add ports 11 tagged
Is that right ?

i will report back . Office closed for next 2 days . Thanks .

Paul_Russo
Extreme Employee
Sumeet You need to change your default route for the switch . You currently have it set to 192.168.0.1 which is the IP address of VLAN 34. I am assuming the main router is something like 192.168.0.254 let's say. Something that is on the same subnet as 192.168.0.1. You need to delete the current iproute and add a new one for the IP address to the next hop router. P

sumeet
New Contributor
After I added
configure vlan dhcp-options default-gateway
Now I am able to ping laptops having different untagged vlan .
Now , i will try to connect laptop to my system which accepts tagged input .
QUESTION
I am aiming for following
Say - my DNS server is 196.1.105.47 . My extreme networks switch does not know the direct route for reaching dns-server. I want all ip packets with similiar unknown destination to be sent to port having vlan34 untagged (currently port 11) . Port 11 will be connected to LAN which is source for internet .

rbrt
Contributor
The laptop is missing a gateway (should be 192.168.1.1 in this case). Without gateway, it will never reach anything outside its subnet.

Paul_Russo
Extreme Employee
Sumeet The configure iproute command is for the switch to route out of the sub nets it has. What you don't have is the command for the switch to hand out a default gateway which is a dhcp option that I mentioned above. Not having this means the end station doesn't know the router IP address to route out. Add this command. configure vlan dhcp-options default-gateway 192.168.1.1 Let's us know how it goes P
GTM-P2G8KFN