cancel
Showing results for 
Search instead for 
Did you mean: 

dhcp ip allocation for particular vlan

dhcp ip allocation for particular vlan

sumeet
New Contributor
hi , we have extreme networks summit x460-24t switch . I want to do the following
switch should assign ip to dhcp client for particular vlan . All packet IP's unknown to switch should be passed from port 1 .

example in cisco we had

ip dhcp pool vlan200
network 172.16.120.0 255.255.255.0
dns-server 196.1.105.47
default-router 172.16.120.1
lease infinite
!
interface Vlan34
ip address 192.168.0.11 255.255.255.0
!
interface GigabitEthernet0/1
switchport access vlan 34
mls qos vlan-based
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1

I tried following in extreme

create vlan "vlan200"
configure vlan vlan131 tag 200
configure vlan vlan200 ipaddress 10.10.10.1 255.255.255.0
configure vlan vlan200 dhcp-address-range 10.10.10.2 - 10.10.10.10

Where am I going wrong ?
15 REPLIES 15

rbrt
Contributor
Hi Sumeet,

Assuming that the second line means "configure vlan vlan200 tag 200" you are basically just missing a default route. The Cisco command
ip route 0.0.0.0 0.0.0.0 192.168.0.1
would be
configure iproute add default 192.168.0.1
in Extreme XOS. For that to work however you would need
  • a VLAN that has an IP address in that network (in your Cisco example VLAN 34).
  • IP forwarding enabled on both VLANs (enable ipforwarding vlan ).
And this should be it.
GTM-P2G8KFN