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Dynamic LAG does not Reform when partnered Cisco device is Restarted

Dynamic LAG does not Reform when partnered Cisco device is Restarted

FAQ_User
Extreme Employee
Article ID: 13296

Products
Matrix E1
Matrix N-Series DFE, S-Series
SecureStacks, I-Series, G-Series, D-Series

Changes
Connected to a Cisco switch with the intent of forming a 802.3ad Dynamic LAG.

Symptoms
The LAG initially forms; but if the Cisco is restarted (without breaking link) at any time, the LAG drops and does not re-form.

Cause
This condition occurs because Enterasys products by default use "long" LAG timers, advertising via the Link Aggregation Control Protocol (LACP) only upon ethernet link and then every 30 seconds thereafter.

When the Cisco comes up and doesn't hear any LACP advertisements, even in the recommended "lacp passive" mode ('
code:
channel-protocol lacp
', '
code:
channel-group
<
group
>
code:
mode passive
') it attempts to form a Cisco-proprietary Port Aggregation Protocol (PAgP) connection - which the Enterasys switch doesn't recognize.

When in some manner the port link state is cycled, LACP is advertised and all is well: LACP on both ends.

Solution/Workaround
Set the Enterasys switch's
code:
aadminstate
to use "short" timers, as discussed in 5340. This advertises LACP upon ethernet link and then every second thereafter - which is frequent enough to prevent the Cisco from transitioning from LACP to PAgP mode as it negotiates with its LAG peer.

Workaround:
Fully reboot either the Cisco or Enterasys device (breaking the link state), or disconnect then reconnect the LAG links.
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