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S/N-Series issues 'PIM_BAD_SYSTEMPORT' Error messages

S/N-Series issues 'PIM_BAD_SYSTEMPORT' Error messages

FAQ_User
Extreme Employee
Article ID: 14749

Products
S-Series
Matrix N-Series DFE

Changes
Recently upgraded firmware between major release lines, for example 7.21 -> 7.31 or 7.62 -> 7.71.

Symptoms
Syslog or Logging Buffer ('show support') display one or more "PIM_BAD_SYSTEMPORT" messages; for example:
<
code:
165
>
code:
Jul 20 14:37:32 10.1.2.3 BrdgMIB[4.tusrAppInit]restoreNvPortConfig: CPiMgrApi::GetSystemPortFromPersistKey(1200) == PIM_BAD_SYSTEMPORT


Cause
The Bridge Port nonvolatile data restore routine has tried to map an invalid port persistKey to its corresponding system port, typically because the key bindings for certain system ports have changed, between two firmware versions.

This is not a commonly reported issue.

Solution/Workaround
Functions as Designed (FAD).

Workaround:
Either reload the config from a previous system outfile (5035) (in extreme cases after powering off the chassis, then pulling all blades, then flipping dip switch 7 on each, then powering on the chassis, then reinstalling each blade and confirming a clean boot), or manually reconfigure what are presumably missing port settings. Either method should re-establish the port data in NVRAM.

Regarding the affected port number to review for possible missing configs, the cited port number ("1200", in this example) should translate to a conventional ethernet port number (i.e. ge.x.x) using the trap-port numbering discussion in 5567.
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