cancel
Showing results for 
Search instead for 
Did you mean: 
Dana_Breckbill
Extreme Employee

Notice Summary:

When duplicate SNMP communities are configured prior to an XCO upgrade to 4.0.2, upgrade fails at the inventory database migration step (dcapp_asset). This issue can also happen due to duplicate “MigrationComplete” entries which can be seen on deployments that have undergone multiple upgrades.

Background:

XCO 4.0.2 restricts duplicate SNMP community entries. If there are duplicate community entries from previous deployments, then upgrading to 4.0.2 will fail.

Impact:

  • Affects any upgrade from previous XCO versions to XCO 4.0.2 where the dcapp_asset.snmp_community table contains duplicate entries with the same Device ID and Encrypted String.
  • The XCO 4.0.2 code itself adds a unique constraint that prevents new duplicates from forming post-upgrade. Once upgraded successfully, the issue will not recur.

Products Affected:

ExtremeCloud Orchestrator (XCO) Embedded TPVM

ExtremeCloud Orchestrator (XCO) Server

Software Affected:

XCO 4.0.2, 4.0.3, 4.04, and 4.0.5

Symptoms:

XCO fails to upgrade.

  • Installer exits with status code 1 within seven seconds of attempting to migrate the database
  • No clear SQL error in the output
  • XCO automatically rolls back each attempt

Database log error:

[ERROR] Slave SQL: Error 'Duplicate entry '3-' for key 'snmp_community_device_id_encrypted_name'' on query. Query: 'ALTER TABLE snmp_community ADD CONSTRAINT snmp_community_device_id_encrypted_name UNIQUE (device_id, encrypted_name)' Internal MariaDB error code: 1062

Solution:

  1. Contact Extreme GTAC to obtain binary and for information on how to repair the tables.
  2. Take a XCO database backup: efa system backup 
  3. Run the provided engineering binary to detect duplicates across the following:
    • snmp_community
    • snmp_group
    • snmp_host
    • snmp_user
    • snmp_view
  1. Validate removal of the duplicates. 
  2. Proceed with the XCO upgrade to 4.0.2. 

 

  • Code fix included in XCO 4.1.0. The upgrade process will automatically detect and address duplicate entries before migrating the table, removing the need for manual intervention. 

 

Please see the full Field Notice here for more details and future updates.

GTM-P2G8KFN