11-17-2022 06:09 PM - edited 11-18-2022 07:51 AM
Dear network colleagues,
I'm currently building up a small Fabric with IS-IS and SPBm on GNS3. Sadly I run into the issue that I see my neighbours via "show isis adjacencies" and also reach them via ping "ping x.x.x.x", but the nodes behind them are not visible and not reachable from the same node.
I remember that I used a config like this on a physical machine and it was running. Maybe I got an error in my config or GNS3 has an internal virtualisation problems or limitations. The software version I run in GNS3 is "2.2.35.1" with an image of "VOSS-8.4", but with other images I had the same issue. Maybe one of you can help, thanks in advance.
This is the topology of the network:
This is the configuration of the "VS7200-A" (They are all configured identical, just the parameters change)
----------------------------------------------------------------------------------------------------------------------------------------
en
conf t
cli timeout 3600
prompt "VS7200-A"
clock time-zone Europe Berlin
sys mtu 9600
#
# SPBM CONFIGURATION
#
spbm
spbm ethertype 0x8100
#
# LACP CONFIGURATION
#
vlacp enable
lacp enable
#
# VRF CONFIGURATION
#
ip vrf mgmt vrfid 500
#
# PORT CONFIGURATION - PHASE I
#
interface GigabitEthernet 1/2-1/4
encapsulation dot1q
exit
#
# ISIS SPBM CONFIGURATION
#
router isis
spbm 1
spbm 1 nick-name 0.72.01
spbm 1 b-vid 4051-4052 primary 4051
spbm 1 ip enable
spbm 1 smlt-virtual-bmac 02:00:07:20:10:0f
spbm 1 smlt-peer-system-id 0200.0720.2000
exit
#
# MLT CONFIGURATION
#
mlt 1 enable name "IST"
mlt 1 member 1/1
mlt 1 encapsulation dot1q
#
# IP PREFIX LIST CONFIGURATION - GlobalRouter
#
ip prefix-list "IST" 10.11.15.4/30 id 1 ge 30 le 30
#
# VLAN CONFIGURATION
#
vlan members remove 1 1/1-1/4 portmember
vlan create 3501 name "vIST" type port-mstprstp 0
vlan i-sid 3501 13501
interface Vlan 3501
ip address 10.11.15.5 255.255.255.252 0
exit
vlan create 4048 name "onboarding-vlan" type pvlan-mstprstp 0 secondary 4049
vlan i-sid 4048 15999999
vlan create 4051 name "BVLAN-1" type spbm-bvlan
vlan create 4052 name "BVLAN-2" type spbm-bvlan
#
# NLS CONFIGURATION
#
mgmt oob
enable
exit
mgmt clip vrf mgmt
ip address 10.254.254.3/32
enable
force-topology-ip
exit
mgmt vlan 4048
mac-offset 0
enable
exit
#
# VIRTUAL IST CONFIGURATION
#
virtual-ist peer-ip 10.11.15.6 vlan 3501
#
# MLT INTERFACE CONFIGURATION
#
interface mlt 1
isis
isis spbm 1
isis spbm 1 l1-metric 50
isis enable
exit
#
# PORT CONFIGURATION - PHASE II
#
interface GigabitEthernet 1/1
untagged-frames-discard
default-vlan-id 0
name "IST"
no shutdown
no spanning-tree mstp force-port-state enable
y
no spanning-tree mstp msti 62 force-port-state enable
exit
interface GigabitEthernet 1/2-1/4
untagged-frames-discard
default-vlan-id 0
no shutdown
isis
isis spbm 1
isis spbm 1 l1-metric 200
isis enable
no spanning-tree mstp force-port-state enable
y
no spanning-tree mstp msti 62 force-port-state enable
exit
#
# IP ROUTE MAP CONFIGURATION - GlobalRouter
#
route-map "suppressIST" 1
no permit
enable
match network "IST"
match protocol local
route-map "suppressIST" 2
permit
enable
match protocol local
exit
#
# IP CONFIGURATION - GlobalRouter
#
ip ecmp
ip ecmp max-path 2
#
# IP CONFIGURATION - VRF
#
router vrf mgmt
ip ecmp
ip ecmp max-path 2
exit
#
# CIRCUITLESS IP INTERFACE CONFIGURATION - GlobalRouter
#
interface loopback 2
ip address 2 10.255.255.3/255.255.255.255
exit
#
# ISIS CONFIGURATION
#
router isis
sys-name "VS7200-A"
ip-source-address 10.255.255.3
is-type l1
system-id 0200.0720.1000
manual-area 49.0001
exit
router isis enable
#
# QOS CONFIGURATION - PHASE II
#
qos queue-profile 1 member add 1/1-1/4
#
# CFM CONFIGURATION - PHASE II
#
cfm spbm mepid 3
cfm spbm enable
#
# ISIS SPBM IPVPN CONFIGURATION
#
router vrf mgmt
ipvpn
i-sid 500
ipvpn enable
exit
#
# ISIS ACCEPT CONFIGURATION - GlobalRouter
#
router isis
accept i-sid 500 enable
exit
#
# ISIS ACCEPT CONFIGURATION - VRF
#
router vrf mgmt
isis accept i-sid 0 enable
exit
#
# IP REDISTRIBUTION CONFIGURATION - GlobalRouter
#
router isis
redistribute direct
redistribute direct route-map "suppressIST"
redistribute direct enable
exit
#
# IP REDISTRIBUTION CONFIGURATION - VRF
#
router vrf mgmt
isis redistribute direct
isis redistribute direct enable
exit
#
# SLPP CONFIGURATION
#
slpp enable
slpp vid 1
#
# I-SID NAME CONFIGURATION
#
i-sid name 15999999 "Onboarding I-SID"
#
# GLOBAL AUTO-SENSE CONFIGURATION
#
auto-sense onboarding i-sid 15999999
#
# SYSTEM CONFIGURATION Phase 2
#
end
#
# IP REDISTRIBUTE APPLY CONFIGURATIONS
#
isis apply redistribute direct
isis apply redistribute direct vrf mgmt