changing slot number in stack

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
On my current working stack, i have 2 x670v and 2x440. I added another 2 x670v to the stack, I want to change the slot numbers of the current 2 x440 to a different stack number. By doing this, will the config also adapt to the change? or would i need to reconfigure it?


Setup is:

x670v <- Slot 1
x670v <- Slot 2
x670v <- Slot 5
x670v <- Slot 6
x440p <- Slot 3
x440p <- Slot 4

What i want:

x670v <- Slot 1
x670v <- Slot 2
x670v <- Slot 3
x670v <- Slot 4
x440p <- Slot 5
x440p <- Slot 6
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
  • lucky

Posted 3 years ago

  • 0
  • 1
Photo of Dave Hammers

Dave Hammers, Dir SW Engineering

  • 3,502 Points 3k badge 2x thumb
You will need to reconfigure for the new slot number
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
Hi!

You need manually configure each slot number (which you want to change), like this:

# configure stacking node-address "xx:xx:xx:xx:xx:xx" slot-number 2
Photo of Johan Hendrikx

Johan Hendrikx

  • 3,040 Points 3k badge 2x thumb
Beware thats the you might change youre configuration  when you change slot numbers.
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
not quite
in this case - probably Master is x670v <- Slot 1, so global configuration will be from Master and not changing, but ports configuration can change, like 4:10
Photo of Johan Hendrikx

Johan Hendrikx

  • 3,040 Points 3k badge 2x thumb
Thats what I mean..  :) 
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
Then Like for you )))
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
Thank you for all the replies, now I am encountering issues with my x440s not finding the master node, and getting stuck at pending-AAA, I have checked all possible cause of this bug, but I haven't been successful, I have tried rebuilding the stack numerous times, but it still can't find the master node, even though i can see it in the "show stacking"

any advice on this?
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
firmware version 
same partition ---could you check this
master capability enabled or disabled
license ?
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
You can see on front panel Master-node = 1 
You can disconnect node on which you want to change stack#, in pending-AAA type REBOOT AS MASTER-CAPABLE, after reboot you can configure this node.
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 12,592 Points 10k badge 2x thumb
Hi,
No information in the logs of the master node?
The x440s are configured as Standby node, not Master-Capable (as you are very likely to have a license mismatch)?
If you have unconfigured the x440s stacking config, have you configured back the enhanced protocol for stacking?
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
Hi

partition used = secondary
firmware = summitX-15.6.1.4.xos
x440 = master capability not enabled

enabled enhanced protocol.

will attach screenshots
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
Is the partition same on all switches in stack ?
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
x670v switches have the same partition settings, i think x440 has different partition.
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb



As you can see, slot 3 which is the x440 switch, can be seen in the stack topology but cannot be configured, and is unable to see the master node. causing it to be stuck at AAA
(Edited)
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
Put the x440 in same partition as the x670 switches
This will solve ur problem
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
if you mean, all on secondary? it is already in it. if not, what do you mean? how do I do this?
(Edited)
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
you might have to load the image again to x440's so that it is loaded to the right partition
then reboot.
You should be able to do this slot by slot.
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
check if you have the below commands
download image <tftpip> image.exos partition <name> slot 3/4
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
Easiest way to upgrade x440 's as standalone to the right partition and add it to stack again
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
hi,

I have done what you have suggested, and still this persists :(
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
could you check the license level on all switches.
you can edit stacking license on x440.
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
hi parthiban,

this is the current settings:


 show stacking configuration
Stack MAC in use: <none>          
Node               Slot         Alternate          Alternate     
MAC Address        Cfg Cur Prio Mgmt IP / Mask     Gateway         Flags     Lic
------------------ --- --- ---- ------------------ --------------- --------- ---
*00:04:96:98:78:25 1   1   Auto <none>             <none>          CcEe--iNn Aa
 00:04:96:98:99:ba 2   2   Auto <none>             <none>          CcEe--iNn Aa
 00:04:96:97:a5:5c 3   3   Auto <none>             <none>          CcEe--iNn Aa




saw this on the log files:

02/24/2015 16:59:24.42 <Warn:DM.Warning> Slot-2: Slot-3 FAILED (1) License Mismatch
02/24/2015 16:59:24.37 <Warn:DM.Warning> Slot-1: Slot-3 FAILED (1) License Mismatch
02/24/2015 16:59:24.37 <Crit:NM.NodeStateFail> Slot-1: Slot-3 has failed for the reason of "License Mismatch".
(Edited)
Photo of Alexandr P

Alexandr P, Embassador

  • 11,828 Points 10k badge 2x thumb
That's mean - you have  License Mismatch :-) 
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
yes, i get that, :P but i don't get where the license mismatch is, all are of the same setting :P
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
configure stacking {node-address node-address | slot slot-number} license-level[core | advanced-edge | edge]
Description
Allows you to restrict the license level at which the node operates.

Try this command and reboot the slot
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
# show stacking slot X detail
will show you more information about what slot have license mismatch.
look at this outputs and compare them
Photo of Gene Fontanilla

Gene Fontanilla

  • 504 Points 500 badge 2x thumb
Hi Parthibam,

THANK YOU VERY MUCH!

i found out what the problem is, our x440 doesn't have advanced edge license!

thank you for the patience on this matter.

regards! and more power
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
Its Glad to know you've found the problem.
Thanks for asking right questions in forum.