Connecting S-series with X450-G2, RSTP Error: "Multiple BPDU sources received"

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
i connect a s-series (Core - V8.31.01) with a X450-G2 (Edge, V15.6.1) with configured RSTP.

Immediatelly with the first connect of this 2 switches, the s-series complaining with:
S8(su)-><165>Sep 18 18:49:04 172.16.255.248 LinkTrap[1]Interface tg.1.1 is Down.
<165>Sep 18 18:49:04 172.16.255.248 Spantree[1]Receive Event: Multiple BPDU sources received on Port = tg.1.2, BPDU Bridge MAC = 00:04:96:99:a1:e5 Port = 52 Prior Bridge MAC = 00:1f:45:5c:a9:00  Port = 258

S8(su)-><165>Sep 18 18:49:23 172.16.255.248 LinkTrap[1]Interface tg.1.1 is Up.
<165>Sep 18 18:49:23 172.16.255.248 Spantree[1]Receive Event: Multiple BPDU sources received on Port = tg.1.1, BPDU Bridge MAC = 00:04:96:99:a1:e5 Port = 49 Prior Bridge MAC = 00:1f:45:5c:a9:00  Port = 257

What does this error message will tell me ??

Regards
Photo of M.Nees

M.Nees, Embassador

  • 9,598 Points 5k badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Mike D

Mike D, Alum

  • 3,852 Points 3k badge 2x thumb
Hello Mathias,

Take this message literally. 
The S pt-pt rstp link rx's a bpdu from 2 sources - conflicting info.  
   
It's the first data point in your investigation.  Do these two switches own these macs?  Is there a multi-link connection involved -  static or otherwise?

With no knowledge of config on either side and without state and stats info to support analysis, a stab at root cause would be speculation.

If that somehow points you toward a resolution please let us know how it turned out. 
  
If you're able to tell us more it will give the community better traction. We'll work on getting you fixed up. 

Regards,
Mike
       
Photo of M.Nees

M.Nees, Embassador

  • 9,598 Points 5k badge 2x thumb
Hi Michael,

thanks for your apply.

The 2 macs are the mac of the S-series (= root bridge) and the summt switch. between these 2 switches and a second s-series (core switch --> no VSB) we have 2 gigabit fiber links. STP should block one of two - for redundancy.

i had opened a GTAC case (01154370) - but no resolution since opening.

Regards
Photo of Mike D

Mike D, Alum

  • 3,852 Points 3k badge 2x thumb
Hey Matthias,

Looks like GTAC sees the same 'multiple bpdu sources' message you see if your config is used in our lab.   
That's destined to be another fix out of the way - for you and for the rest of us.    

Thank you for the follow up. 
Regards,
Mike
  
Photo of M.Nees

M.Nees, Embassador

  • 9,598 Points 5k badge 2x thumb
GTAC tells me that this issue is fixed with next XOS V16.1.2.
Photo of Mike D

Mike D, Alum

  • 3,852 Points 3k badge 2x thumb
Hello Matthias,


The thread details will be added to our knowledge base in short order.  

Migrated/mixed configs are becoming more common and this problem is sure to be experienced by others.  As the first to report the problem from the field, your experience will benefit other community members in the same predicament.  Networking karma ++

Thank you for closing the loop on this item - and kudos to the GTAC crew for their diligent work and a quick turnaround. 

The news as it happen folks.  Right here on the hub!
Photo of Gareth Mitchell

Gareth Mitchell, Extreme Escalation Support Engineer

  • 5,670 Points 5k badge 2x thumb
Photo of M.Nees

M.Nees, Embassador

  • 9,598 Points 5k badge 2x thumb
Hi Gareth,

thanks for writing a KB article. This is a good thing for any other user who have the same problem.

But especially regarding this i miss much more technical details which describe this issue better (including a little bit of the technical background) and maybe the later workaround. But many of the new GTAC KB article are too short and to shallow (without details).

If you can hand in later this the others and i are grateful.


Regards