Edge port topology change

  • 0
  • 1
  • Question
  • Updated 4 months ago
  • Answered
Hi, sometimes i get confused probably because i am missing something very obvious but im unable to see it.

For some reason a port configured as an edge port is initiating topologies changes, the port configuration is as follows:
configure stpd s0 ports link-type edge 3:32
configure stpd s0 ports edge-safeguard enable 3:32
configure stpd s0 ports bpdu-restrict enable 3:32 
on the switch logs i see the following:
<Summ:STP.State.Topology> Slot-1: [s0:3:32] Topology Change Detected locally
I have 802.1w configured on my switches and they are on version 22.x. I dont understand why this is happening, from my understanding of 802.1w only non-edge ports that move to forwarding state cause a topology change. So why am i seeing this on my logs a topology change from an edge port? Can anyone enlighten me?
Photo of GONÇALO NUNO CONTENTE PIMENTEL DA SILVA REIS

Posted 5 months ago

  • 0
  • 1
Photo of Brian Austin

Brian Austin, Employee

  • 412 Points 250 badge 2x thumb
Can you provide us with a little more information such as the output of the following command show stpd  s0 ports 3:32 detail?
Photo of Necheporenko, Nikolay

Necheporenko, Nikolay, Employee

  • 1,350 Points 1k badge 2x thumb
Hello GONÇALO,

Please check the issue on the EXOS 22.2.1.5-patch1-4, as it is not affected by next CRs

“CR#xos0069839 - Operational Edge status is inconsistent if edge-safeguard is enabled before configuring link as edge”. 
“CR xos0069755 - when edge port goes down topology change is incorrectly triggered”

Or you may wait for December's '18 patch 22.3.1.4

Best Regards,
Nikolay
(Edited)
Hi Nikolay

i have update recently all my switches and im running  22.3.1.4-patch1-4

Regards
Hi Nikolay

Can you explain me what is "next CRs"?

Regards
Photo of Necheporenko, Nikolay

Necheporenko, Nikolay, Employee

  • 1,350 Points 1k badge 2x thumb
Hello,

That are CRs about known STP issues, and 22.3.1.4p1-4 is affected and does not contain fixes. Fixes are expected in a next patch 22.3.

Best Regards,
Nikolay
Hi Brian,

Here is the output:
sh stpd s0 port 3:32 detail
Stpd: s0        Port: 3:32      PortId: 8120    Stp: ENABLED    Path Cost: 20000
Port Mode         : 802.1D              Port Role          : Designated
Port State        : FORWARDING          Topology Change Ack: FALSE
Port Priority     : 128
Designated Root   : 20:00:74:a0:2f:0c:dd:80     Designated Cost: 20000, IntCost: 0
Designated Bridge : 80:00:02:04:96:9e:5e:41     Designated Port Id: 8120
Partner STP version     : Dot1w
Restricted Role         : Disabled
Active Role             : Disabled
Edge Port Safe Guard    : Enabled
Bpdu Restrict           : Enabled
maxAge: 20      msgAge: 1       fwdDelay: 15    helloTime: 2    maxHops: 20
Restricted TCN          : Off
Loop Protect            : Off
Loop Protect Partner    : Incapable
Operational Edge        : FALSE
Auto Edge               : On
Participating Vlans: Aulas 

thanks
Hi, All as i said before on EXOS 22.3.1.4 for some unknown reasons ports configured with link-type edge are initiating topology changes, this happens because the operational edge goes from True to False and the port starts behaving has if there was no link-type edge configuration. Thanks to Nicolay i was informed that this would be corrected in the next patch.

Since there is no next patch yet for EXOS 22.3.1.4 i have taken the initiative to try the new EXOS release 22.4.1.4. After reading the resolved issues i was convinced that this issue was solved since CR xos0069755 is among the list of solved issues.

I would like to underline that i am not sure if CR xos0069755 relates to the issue i am experiencing even though the end result is the same, the port incorrectly trigger a topology change.

All the ports connected to end devices on my network have the following configuration
configure stpd s0 ports link-type edge 3:32
configure stpd s0 ports edge-safeguard enable 3:32
configure stpd s0 ports bpdu-restrict enable 3:32 
this can be verified with the command "sh stpd s0 port 3:32 detail", the important lines from the output are as follows.
Edge Port Safe Guard    : Enabled
Bpdu Restrict           : Enabled
Operational Edge        : TRUE
Auto Edge               : On
After changing a port vlan the Operational Edge goes to FALSE and when the port links up a topology change is triggerd even though the port is still configured with the link-type edge. I have tried to disable the Auto Edge, but no luck.
Edge Port Safe Guard    : Enabled
Bpdu Restrict           : Enabled
Operational Edge        : FALSE Auto Edge               : On
The only solution i have found for the moment, is uppon changing a port vlan, double check if Operational Edge is FALSE and if so the port must be reconfigured with the link-type edge command in the following order to bring the Operational EDGE to TRUE.
configure stpd s0 ports link-type edge 3:32
configure stpd s0 ports edge-safeguard enable 3:32 
configure stpd s0 ports bpdu-restrict enable 3:32
Regards
Gonçalo Reis