EWC doesn't changes rule after guest registration

  • 0
  • 1
  • Problem
  • Updated 4 years ago
I've configures NAC as an external captive portal in EWC. When the client connects, it gets the Unregistered policy. After registration, the NAC changes the clients policy to Guest Access, but the EWC remains the Unregistered. I need to disassociate the client form the EWC to set the EWC the Guest Access profile. The NAC and the EWC are synchronized to the same NTP server and are in the same VLAN. Does somebody have any idea how to resolve this issue?
Photo of Gabriel Bagita

Gabriel Bagita

  • 560 Points 500 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,710 Points 20k badge 2x thumb
The time between the controller and the NAC server is off. Please confirm you match on both. 
Photo of Charlie Altherr

Charlie Altherr

  • 400 Points 250 badge 2x thumb
I had a similar issue about a year ago.  Root cause was time variation between NAC server and controller.  Even though NTP was configured on the controller, time had drifted significantly.  Manually setting the time on the controller resolved the immediate issue.  I had to delete the controller NTP configuration and recreate it to resolve root cause.  Issue has not returned.
Photo of Gabriel Bagita

Gabriel Bagita

  • 560 Points 500 badge 2x thumb
Hi Guys,

thank you for the advice.The problem is resolved now. It wasn't caused by the different time on EWC and NAC. The issue was that on the NAC in the RFC3576 setting I have CoA turned on, but my EWC's firmware didn't support CoA. When I turned off CoA, I got the right policy.
Photo of Mario Hobel

Mario Hobel

  • 60 Points
Hi Gabriel !

I also tried to configure ewc with nac external captive Portal, but i can't get it running. Can you help me. Perhaps do you have an step to step Guide for me ? I can't find any Information or guides for this.

Thanks