cancel
Showing results for 
Search instead for 
Did you mean: 

Can the Default VLAN 1 be deleted or disabled - VCS Logical Chasis

Can the Default VLAN 1 be deleted or disabled - VCS Logical Chasis

Anonymous
Not applicable
Hi,

Would like to remove or delete the default VLAN 1 as its not being used, but can't find the command to do it if in fact it is possible, see below:

code:
Col-xxx-VSP-Sw11(config-Port-channel-66)# do show vlan brief
Total Number of VLANs configured : 24
Total Number of VLANs provisioned : 24
Total Number of VLANs unprovisioned : 0
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT (t)-Tagged
================ =============== ========================== =============== ====================
1 default ACTIVE Po 10(t)
Po 11(t)
Po 64(t)
Po 65(t)
Po 66(t)


Col-xxx-VSP-Sw11(config)# interface Port-channel 66
Col-xxx-VSP-Sw11(config-Port-channel-66)# switchport trunk allowed vlan remove 1

Col-xxx-VSP-Sw11(config)# no interface Vlan 1
%%Error: Not Allowed to Delete Vlan Interface 1

Col-xxx-VSP-Sw11(config)# no vlan ?
Description: Vlan commands
Possible completions:
classifier Vlan classification commands
dot1q Configure dot1q parameters


Col-xxx-VSP-Sw11# show running-config interface Port-channel 66
interface Port-channel 66
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan add 22,30,64,70-71,146-151,240,252,999,2002,3333
no switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown



As can be seen VLAN 1 is being tagged on port-channel 66. I would like to remove it from all ports, and can see some of the commands I used.

Be grateful for any help.

Many thanks
4 REPLIES 4

Anonymous
Not applicable
Hi Mike,

That's great, thanks for the info.

Cheers,

Martin

Michael_Morey
Extreme Employee
By default switchport trunk interfaces are tagged with the Native VLAN:

code:
VDX1(conf-if-te-1/0/10)# do show run int te 1/0/10
interface TenGigabitEthernet 1/0/10
switchport
switchport mode trunk
switchport trunk allowed vlan add 1000
switchport trunk tag native-vlan
spanning-tree shutdown
fabric isl enable
fabric trunk enable
no shutdown

VDX1(conf-if-te-1/0/10)# do show vlan bri
Total Number of VLANs configured : 11
Total Number of VLANs provisioned : 11
Total Number of VLANs unprovisioned : 0
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT (t)-Tagged
================ =============== ========================== =============== ====================
1 default ACTIVE Po 1(t)
Po 2(t)
Po 100(t)
Te 1/0/10(t)
Te 1/0/22(t)


On a default setup, there is no way to remove the native VLAN short of configuring the interface as a L3 interface. That being said, it is possible to accomplish this with the command:

code:
switchport mode trunk-no-default-native


The catch is that this command is only available when "Virtual-Fabric" is enabled

code:
conf t
vcs virtual-fabric enable


Example of completed config:

code:
VDX1# show run int te 1/0/10
interface TenGigabitEthernet 1/0/10
switchport
switchport mode trunk-no-default-native
switchport trunk allowed vlan add 1000
spanning-tree shutdown
fabric isl enable
fabric trunk enable
no shutdown
!
VDX1# show vlan bri
Total Number of VLANs configured : 11
Total Number of VLANs provisioned : 11
Total Number of VLANs unprovisioned : 0
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT (t)-Tagged
================ =============== ========================== =============== ====================
1 default ACTIVE Po 1(t)
Po 2(t)
Po 100(t)
Te 1/0/22(t)


I would recommend you review the documentation regarding "Virtual-Fabric" mode to see if it will have any adverse impact to your network. Also please be advised that once you configure the switch port with with "trunk-no-default-native" mode, you will have to re-tag all of your previous VLANs as they are removed anytime you change the switch-port mode.

Thanks,

Mike Morey
Principal Technical Support Engineer
Michael Morey
Principal Technical Support Engineer
Extreme Networks

Anonymous
Not applicable
Hi Truyen,

Thanks for getting back.

Ok. Is there a way to remove the default VLAN from the interface if I can't delete it?

Its being added tagged, so that is some protection if nothing else.

Thanks

Truyen_Phan
Extreme Employee
Hi Martin,

Unfortunately, the default VLAN 1 is not allowed to be removed.
GTM-P2G8KFN